summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/inputlircd/inputlircd-0.0.1_pre15-r3.ebuild')
-rw-r--r--app-misc/inputlircd/inputlircd-0.0.1_pre15-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/inputlircd/inputlircd-0.0.1_pre15-r3.ebuild b/app-misc/inputlircd/inputlircd-0.0.1_pre15-r3.ebuild
new file mode 100644
index 000000000000..c7da09f84652
--- /dev/null
+++ b/app-misc/inputlircd/inputlircd-0.0.1_pre15-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Inputlirc daemon to utilize /dev/input/event*"
+HOMEPAGE="https://github.com/gsliepen/inputlirc"
+SRC_URI="http://gentooexperimental.org/~genstef/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~loong ppc ppc64 ~riscv x86"
+
+src_prepare() {
+ local ver="$(best_version sys-kernel/linux-headers)"
+ ver=${ver#sys-kernel/linux-headers-}
+ if ver_test ${ver} -ge 4.4; then
+ eapply "${FILESDIR}/inputlircd-linux-4.4-fix.patch"
+ fi
+
+ sed -e 's|$(CFLAGS)|$(CFLAGS) $(LDFLAGS)|' -i Makefile || die
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ newinitd "${FILESDIR}"/inputlircd.init.2 inputlircd
+ newconfd "${FILESDIR}"/inputlircd.conf inputlircd
+}