summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/jdupes')
-rw-r--r--app-misc/jdupes/Manifest1
-rw-r--r--app-misc/jdupes/jdupes-1.27.3.ebuild49
-rw-r--r--app-misc/jdupes/jdupes-9999.ebuild49
-rw-r--r--app-misc/jdupes/metadata.xml22
4 files changed, 121 insertions, 0 deletions
diff --git a/app-misc/jdupes/Manifest b/app-misc/jdupes/Manifest
new file mode 100644
index 000000000000..316a49a0e4a5
--- /dev/null
+++ b/app-misc/jdupes/Manifest
@@ -0,0 +1 @@
+DIST jdupes-1.27.3.tar.gz 174779 BLAKE2B f6697df396e2f6e285d17465de183904f87e0b34b2a46bb7aeea6da8696ae31951af3f2f26b6e71cedbd25c756456ece055b99e76f92eadabd79a01183161d59 SHA512 ee2d60a922558e2aa819f9074fb0b3b38cc93ddc4f6ca3a1d0dd8731c4ecf72d1b6cbb0bc85be7cd63b21f7d9138efadfb64208122a4eebd4e55756a3edd5bcc
diff --git a/app-misc/jdupes/jdupes-1.27.3.ebuild b/app-misc/jdupes/jdupes-1.27.3.ebuild
new file mode 100644
index 000000000000..b0ea5eb22c14
--- /dev/null
+++ b/app-misc/jdupes/jdupes-1.27.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Identify duplicate files on the filesystem"
+HOMEPAGE="https://codeberg.org/jbruchon/jdupes"
+if [[ "${PV}" == *9999 ]] ; then
+ EGIT_REPO_URI="https://codeberg.org/jbruchon/jdupes.git"
+ inherit git-r3
+else
+ SRC_URI="https://codeberg.org/jbruchon/jdupes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}
+ KEYWORDS="amd64"
+fi
+LICENSE="MIT"
+SLOT="0"
+
+# Please keep a careful eye on the minimum libjoycode version! (Just pick
+# latest released at the time if necessary.)
+DEPEND=">=dev-libs/libjodycode-3.0"
+RDEPEND="${DEPEND}"
+
+IUSE="+dedupe hardened"
+
+# missing test.sh script
+# https://github.com/jbruchon/jdupes/issues/191
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e '/PREFIX/s/=/?=/' Makefile || die
+ default
+}
+
+src_compile() {
+ tc-export CC
+ local myconf=(
+ $(usex dedupe 'ENABLE_DEDUPE=1' '')
+ $(usex hardened 'HARDEN=1' '')
+ )
+ emake ${myconf[@]}
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ einstalldocs
+}
diff --git a/app-misc/jdupes/jdupes-9999.ebuild b/app-misc/jdupes/jdupes-9999.ebuild
new file mode 100644
index 000000000000..43ccea82ffe8
--- /dev/null
+++ b/app-misc/jdupes/jdupes-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Identify duplicate files on the filesystem"
+HOMEPAGE="https://codeberg.org/jbruchon/jdupes"
+if [[ "${PV}" == *9999 ]] ; then
+ EGIT_REPO_URI="https://codeberg.org/jbruchon/jdupes.git"
+ inherit git-r3
+else
+ SRC_URI="https://codeberg.org/jbruchon/jdupes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}
+ KEYWORDS="~amd64"
+fi
+LICENSE="MIT"
+SLOT="0"
+
+# Please keep a careful eye on the minimum libjoycode version! (Just pick
+# latest released at the time if necessary.)
+DEPEND=">=dev-libs/libjodycode-3.0"
+RDEPEND="${DEPEND}"
+
+IUSE="+dedupe hardened"
+
+# missing test.sh script
+# https://github.com/jbruchon/jdupes/issues/191
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e '/PREFIX/s/=/?=/' Makefile || die
+ default
+}
+
+src_compile() {
+ tc-export CC
+ local myconf=(
+ $(usex dedupe 'ENABLE_DEDUPE=1' '')
+ $(usex hardened 'HARDEN=1' '')
+ )
+ emake ${myconf[@]}
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ einstalldocs
+}
diff --git a/app-misc/jdupes/metadata.xml b/app-misc/jdupes/metadata.xml
new file mode 100644
index 000000000000..61f7438c4a27
--- /dev/null
+++ b/app-misc/jdupes/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>jakov.petrina@sartura.hr</email>
+ <name>Jakov Petrina</name>
+ </maintainer>
+ <maintainer type="person" proxied="proxy">
+ <email>jsmolic@gentoo.org</email>
+ <name>Jakov Smolić</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="dedupe">Enable deduplication support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">jbruchon/jdupes</remote-id>
+ </upstream>
+</pkgmetadata>