summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/jo')
-rw-r--r--app-misc/jo/Manifest1
-rw-r--r--app-misc/jo/files/jo-1.9-bashcomp.patch12
-rw-r--r--app-misc/jo/jo-1.9.ebuild28
-rw-r--r--app-misc/jo/metadata.xml11
4 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/jo/Manifest b/app-misc/jo/Manifest
new file mode 100644
index 000000000000..219711075384
--- /dev/null
+++ b/app-misc/jo/Manifest
@@ -0,0 +1 @@
+DIST jo-1.9.gh.tar.gz 200414 BLAKE2B f316e7ba43d63ade5888e2bb3288290f026bc1fcb0975a06714892a8e3695158a2bccbb5ceef25bccc3e6f92fe53d18bf25077516c75091dde571390dea07a3c SHA512 222ca7d85593a2038ed527c08c16fbdcabd97b83ba026148ce9307d2523a2c2f466eb38fff03e2dbf0e45f8b93d9e0737bdb719e2be567ce9cc09d362e8c7911
diff --git a/app-misc/jo/files/jo-1.9-bashcomp.patch b/app-misc/jo/files/jo-1.9-bashcomp.patch
new file mode 100644
index 000000000000..677eac6bb255
--- /dev/null
+++ b/app-misc/jo/files/jo-1.9-bashcomp.patch
@@ -0,0 +1,12 @@
+diff --git a/Makefile.am b/Makefile.am
+index 2ac7e84..265cce8 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -14,6 +14,7 @@ zshcompdir = $(datadir)/zsh/site-functions
+ dist_zshcomp_DATA = jo.zsh
+ install-data-hook:
+ mv -f $(DESTDIR)$(zshcompdir)/jo.zsh $(DESTDIR)$(zshcompdir)/_jo
++ mv -f $(DESTDIR)$(bashcompdir)/jo.bash $(DESTDIR)$(bashcompdir)/jo
+
+ uninstall-local:
+ rm -f $(DESTDIR)$(zshcompdir)/_jo
diff --git a/app-misc/jo/jo-1.9.ebuild b/app-misc/jo/jo-1.9.ebuild
new file mode 100644
index 000000000000..1a284f312616
--- /dev/null
+++ b/app-misc/jo/jo-1.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="JSON output from a shell"
+HOMEPAGE="https://github.com/jpmens/jo"
+SRC_URI="https://github.com/jpmens/jo/releases/download/${PV}/${P}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2+ MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=(
+ AUTHORS
+ README
+)
+
+PATCHES=(
+ "${FILESDIR}/jo-1.9-bashcomp.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
diff --git a/app-misc/jo/metadata.xml b/app-misc/jo/metadata.xml
new file mode 100644
index 000000000000..802c407121f9
--- /dev/null
+++ b/app-misc/jo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jpmens/jo</remote-id>
+ </upstream>
+</pkgmetadata>