summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/jpipe/jpipe-0.2.0-r1.ebuild')
-rw-r--r--app-misc/jpipe/jpipe-0.2.0-r1.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/app-misc/jpipe/jpipe-0.2.0-r1.ebuild b/app-misc/jpipe/jpipe-0.2.0-r1.ebuild
index af7dafc3fcb3..df98fabb80f0 100644
--- a/app-misc/jpipe/jpipe-0.2.0-r1.ebuild
+++ b/app-misc/jpipe/jpipe-0.2.0-r1.ebuild
@@ -1,17 +1,19 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
GO_OPTIONAL=1
DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
-inherit go-module distutils-r1
+inherit go-module distutils-r1 pypi
DESCRIPTION="Command line interface to JMESPath"
HOMEPAGE="https://github.com/pipebus/jpipe https://github.com/jmespath/jp/pull/30 http://jmespath.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- !python? ( https://dev.gentoo.org/~zmedico/dist/jpipe-0.2.0-deps.tar.xz )"
+SRC_URI+="
+ !python? ( https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz )
+"
LICENSE="Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
@@ -20,7 +22,7 @@ RESTRICT+=" test"
IUSE="jpp-symlink jp-symlink python test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
-BDEPEND="
+BDEPEND="${DISTUTILS_DEPS}
!python? (
app-arch/unzip
>=dev-lang/go-1.12
@@ -39,6 +41,8 @@ RDEPEND="
)
"
+distutils_enable_tests pytest
+
src_unpack() {
if use python; then
default
@@ -61,6 +65,8 @@ python_prepare_all() {
if ! use jp-symlink; then
sed -e '/"jp = jpipe/d' -i setup.py || die
fi
+ sed -e 's:entry_points()\["console_scripts"\]:entry_points().select(group="console_scripts"):' \
+ -i lib/python/jpipe/cmd/main.py || die
distutils-r1_python_prepare_all
}