summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/lirc/lirc-0.10.1-r4.ebuild')
-rw-r--r--app-misc/lirc/lirc-0.10.1-r4.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/app-misc/lirc/lirc-0.10.1-r4.ebuild b/app-misc/lirc/lirc-0.10.1-r4.ebuild
index fcd0c35415d0..49a4ce8de258 100644
--- a/app-misc/lirc/lirc-0.10.1-r4.ebuild
+++ b/app-misc/lirc/lirc-0.10.1-r4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{10,11,12} )
-inherit eutils flag-o-matic linux-info python-single-r1 systemd xdg-utils
+inherit flag-o-matic linux-info python-single-r1 systemd xdg-utils
DESCRIPTION="decode and send infra-red signals of many commonly used remote controls"
HOMEPAGE="https://www.lirc.org/"
@@ -15,14 +15,14 @@ LIRC_DRIVER_DEVICE="/dev/lirc0"
MY_P=${PN}-${PV/_/-}
if [[ "${PV/_pre/}" = "${PV}" ]]; then
- SRC_URI="mirror://sourceforge/lirc/${MY_P}.tar.bz2"
+ SRC_URI="https://downloads.sourceforge.net/lirc/${MY_P}.tar.bz2"
else
SRC_URI="https://www.lirc.org/software/snapshots/${MY_P}.tar.bz2"
fi
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 x86"
+KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 ~riscv x86"
IUSE="audio +devinput doc ftdi gtk inputlirc static-libs systemd +uinput usb X"
REQUIRED_USE="
@@ -39,7 +39,7 @@ COMMON_DEPEND="
media-libs/alsa-lib
)
$(python_gen_cond_dep '
- dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
')
ftdi? ( dev-embedded/libftdi:0 )
systemd? ( sys-apps/systemd )
@@ -55,9 +55,9 @@ DEPEND="
${COMMON_DEPEND}
dev-libs/libxslt
$(python_gen_cond_dep '
- dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
')
- doc? ( app-doc/doxygen )
+ doc? ( app-text/doxygen )
sys-apps/kmod
sys-kernel/linux-headers
"
@@ -67,7 +67,7 @@ RDEPEND="
gtk? (
x11-libs/vte[introspection]
$(python_gen_cond_dep '
- dev-python/pygobject[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
')
)
inputlirc? ( app-misc/inputlircd )