summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/mc/files')
-rw-r--r--app-misc/mc/files/mc-4.8.23-3933-iso9660-1.patch85
-rw-r--r--app-misc/mc/files/mc-4.8.23-3933-iso9660-2.patch29
-rw-r--r--app-misc/mc/files/mc-4.8.23-gettext-test.patch54
-rw-r--r--app-misc/mc/files/mc-4.8.23-gettext.patch56
-rw-r--r--app-misc/mc/files/mc-4.8.26-ncurses-mouse.patch16
-rw-r--r--app-misc/mc/files/mc-4.8.29-gentoo-tools.patch11
-rw-r--r--app-misc/mc/files/mc-4.8.30-fish_fix_broken_national_characters.patch40
-rw-r--r--app-misc/mc/files/mc-4.8.30-mcdiff-segfault.patch36
-rw-r--r--app-misc/mc/files/mc-4.8.30-musl-tests.patch15
9 files changed, 118 insertions, 224 deletions
diff --git a/app-misc/mc/files/mc-4.8.23-3933-iso9660-1.patch b/app-misc/mc/files/mc-4.8.23-3933-iso9660-1.patch
deleted file mode 100644
index be08e68b296c..000000000000
--- a/app-misc/mc/files/mc-4.8.23-3933-iso9660-1.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-From afdc9719f3e37921b621046f01f23fe6b705f059 Mon Sep 17 00:00:00 2001
-From: Andrew Borodin <aborodin@vmail.ru>
-Date: Sun, 7 Jul 2019 14:44:10 +0300
-Subject: [PATCH 1/2] Ticket #3933: report iso9660 listing errors.
-
-Variation 1:
-
-Steps to reproduce:
-
- * create empty .iso file (touch foo.iso)
- * run 'mc' and press enter on empty .iso
-
-Expected result: some error about invalid file format (sililar to what
-F3 view would yield).
-Actual result: mc elters a file as if it would be empty valid file.
-
-Variation 2:
-Steps to reproduce:
-
- * pick valid .iso file
- * deinstall all helper tools that handle .sio (isoinfo, xorriso, etc.)
- * run 'mc' and press enter on empty .iso
-
-Expected result: some error about invalid file format (sililar to what
-F3 view would yield)
-Actual result: mc enters a file as if it would be empty valid file
-
-Variation 2 is especially confusing for users as it does not hint them
-that they should install a tool to get it working. They just observe
-silently broken behaviour.
-
-Signed-off-by: Andrew Borodin <aborodin@vmail.ru>
----
- src/vfs/extfs/helpers/iso9660.in | 14 +++++++++++---
- 1 file changed, 11 insertions(+), 3 deletions(-)
-
-diff --git a/src/vfs/extfs/helpers/iso9660.in b/src/vfs/extfs/helpers/iso9660.in
-index 8c2240e8e..76273522e 100644
---- a/src/vfs/extfs/helpers/iso9660.in
-+++ b/src/vfs/extfs/helpers/iso9660.in
-@@ -93,6 +93,8 @@ xorriso_rm() {
-
- # tested to comply with isoinfo 2.0's output
- test_iso () {
-+ which isoinfo 2>/dev/null || (echo "isoinfo not found" >&2; return 1)
-+
- CHARSET=$(locale charmap 2>/dev/null)
- if test -z "$CHARSET"; then
- CHARSET=$(locale 2>/dev/null | @GREP@ LC_CTYPE | sed -n -e 's/.*\.\(.*\)"$/\1/p')
-@@ -119,6 +121,8 @@ test_iso () {
- }
-
- mcisofs_list () {
-+ local lsl r
-+
- # left as a reminder to implement compressed image support =)
- case "$1" in
- *.lz) MYCAT="lzip -dc";;
-@@ -133,7 +137,11 @@ mcisofs_list () {
- *) MYCAT="cat";;
- esac
-
-- $ISOINFO -l -i "$1" 2>/dev/null | @AWK@ -v SEMICOLON=$SEMICOLON '
-+ lsl=$($ISOINFO -l -i "$1" 2>/dev/null)
-+ r=$?
-+ test $r -gt 0 && return $r
-+
-+ echo "$lsl" | @AWK@ -v SEMICOLON=$SEMICOLON '
- BEGIN {
- dir="";
- # Pattern to match 8 first fields.
-@@ -183,8 +191,8 @@ shift
- case "$cmd" in
- list)
- xorriso_list "$@" || {
-- test_iso "$@";
-- mcisofs_list "$@";
-+ test_iso "$@" || exit 1
-+ mcisofs_list "$@" || exit 1
- }
- exit 0
- ;;
---
-2.22.0
-
diff --git a/app-misc/mc/files/mc-4.8.23-3933-iso9660-2.patch b/app-misc/mc/files/mc-4.8.23-3933-iso9660-2.patch
deleted file mode 100644
index 173def62eb0b..000000000000
--- a/app-misc/mc/files/mc-4.8.23-3933-iso9660-2.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From c1b6d29b95a373108e8d03ac629dcb03fcec854c Mon Sep 17 00:00:00 2001
-From: Andrew Borodin <aborodin@vmail.ru>
-Date: Sun, 7 Jul 2019 15:51:28 +0300
-Subject: [PATCH 2/2] iso9660: report errors in copyout in case of isoinfo
- usage.
-
-Signed-off-by: Andrew Borodin <aborodin@vmail.ru>
----
- src/vfs/extfs/helpers/iso9660.in | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/vfs/extfs/helpers/iso9660.in b/src/vfs/extfs/helpers/iso9660.in
-index 76273522e..f9c6e50ef 100644
---- a/src/vfs/extfs/helpers/iso9660.in
-+++ b/src/vfs/extfs/helpers/iso9660.in
-@@ -222,8 +222,8 @@ case "$cmd" in
- ;;
- copyout)
- xorriso_copyout "$@" || {
-- test_iso "$@";
-- mcisofs_copyout "$@";
-+ test_iso "$@" || exit 1
-+ mcisofs_copyout "$@" || exit 1
- }
- exit 0
- ;;
---
-2.22.0
-
diff --git a/app-misc/mc/files/mc-4.8.23-gettext-test.patch b/app-misc/mc/files/mc-4.8.23-gettext-test.patch
deleted file mode 100644
index 7e19cd7fa119..000000000000
--- a/app-misc/mc/files/mc-4.8.23-gettext-test.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-https://bugs.gentoo.org/693850
-https://midnight-commander.org/raw-attachment/ticket/3629/mc-3629-Linking-fix-for-gettext.patch
-
-Test change counterpart.
-
---- a/tests/lib/Makefile.am
-+++ b/tests/lib/Makefile.am
-@@ -9,3 +9,3 @@ AM_LDFLAGS = @TESTS_LDFLAGS@
- LIBS = @CHECK_LIBS@ \
-- $(top_builddir)/lib/libmc.la
-+ $(top_builddir)/lib/libmc.la $(LIBINTL)
-
---- a/tests/lib/mcconfig/Makefile.am
-+++ b/tests/lib/mcconfig/Makefile.am
-@@ -11,3 +11,3 @@ AM_LDFLAGS = @TESTS_LDFLAGS@
- LIBS = @CHECK_LIBS@ \
-- $(top_builddir)/lib/libmc.la
-+ $(top_builddir)/lib/libmc.la $(LIBINTL)
-
---- a/tests/lib/search/Makefile.am
-+++ b/tests/lib/search/Makefile.am
-@@ -10,3 +10,3 @@ AM_CPPFLAGS = \
- LIBS = @CHECK_LIBS@ \
-- $(top_builddir)/lib/libmc.la @PCRE_LIBS@
-+ $(top_builddir)/lib/libmc.la @PCRE_LIBS@ $(LIBINTL)
-
---- a/tests/lib/vfs/Makefile.am
-+++ b/tests/lib/vfs/Makefile.am
-@@ -14,3 +14,3 @@ EXTRA_DIST = mc.charsets
- LIBS = @CHECK_LIBS@ \
-- $(top_builddir)/lib/libmc.la
-+ $(top_builddir)/lib/libmc.la $(LIBINTL)
-
---- a/tests/lib/Makefile.in
-+++ b/tests/lib/Makefile.in
-@@ -636 +636 @@ LIBPTH_PREFIX = @LIBPTH_PREFIX@
--LIBS = @CHECK_LIBS@ $(top_builddir)/lib/libmc.la $(am__append_1)
-+LIBS = @CHECK_LIBS@ $(top_builddir)/lib/libmc.la $(LIBINTL) $(am__append_1)
---- a/tests/lib/mcconfig/Makefile.in
-+++ b/tests/lib/mcconfig/Makefile.in
-@@ -542 +542 @@ LIBPTH_PREFIX = @LIBPTH_PREFIX@
--LIBS = @CHECK_LIBS@ $(top_builddir)/lib/libmc.la $(am__append_1)
-+LIBS = @CHECK_LIBS@ $(top_builddir)/lib/libmc.la $(LIBINTL) $(am__append_1)
---- a/tests/lib/search/Makefile.in
-+++ b/tests/lib/search/Makefile.in
-@@ -584,2 +584 @@ LIBPTH_PREFIX = @LIBPTH_PREFIX@
--LIBS = @CHECK_LIBS@ $(top_builddir)/lib/libmc.la @PCRE_LIBS@ \
-- $(am__append_1)
-+LIBS = @CHECK_LIBS@ $(top_builddir)/lib/libmc.la @PCRE_LIBS@ $(LIBINTL) $(am__append_1)
---- a/tests/lib/vfs/Makefile.in
-+++ b/tests/lib/vfs/Makefile.in
-@@ -641 +641 @@ LIBPTH_PREFIX = @LIBPTH_PREFIX@
--LIBS = @CHECK_LIBS@ $(top_builddir)/lib/libmc.la $(am__append_1)
-+LIBS = @CHECK_LIBS@ $(top_builddir)/lib/libmc.la $(LIBINTL) $(am__append_1)
diff --git a/app-misc/mc/files/mc-4.8.23-gettext.patch b/app-misc/mc/files/mc-4.8.23-gettext.patch
deleted file mode 100644
index 3ad67dbe5d40..000000000000
--- a/app-misc/mc/files/mc-4.8.23-gettext.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-https://bugs.gentoo.org/693850
-https://midnight-commander.org/raw-attachment/ticket/3629/mc-3629-Linking-fix-for-gettext.patch
-
-From 2a97524b42eeececd2ecd928a1154da1f5b7378a Mon Sep 17 00:00:00 2001
-From: Andreas Mohr <and@gmx.li>
-Date: Fri, 1 Apr 2016 06:44:22 +0000
-Subject: [PATCH] Linking fix for non-default gettext package
-
-mc lost the linking game if gettext package pulled from outside of system paths.
-(Pulling can be done by suitable C-/CPP/LDFLAGS settings)
-
-Furthermore gettext package depends on libintl (if system lib
-don't provide needed functions) then gettext prepare INITLIBS/LIBINTL variable
-for working libintl pull in from gettext libdir.
-
-https://www.gnu.org/software/gettext/FAQ.html#integrating_undefined
-
-Let respect LIBINTL variable at linking (it is empty if not needed).
-
-Failure example for Solaris 10 with non-system-default gettext package:
-
-Undefined first referenced
- symbol in file
- libintl_bind_textdomain_codeset ./.libs/libinternal.a(args.o)
- libintl_gettext main.o
- libintl_textdomain main.o
- libintl_bindtextdomain main.o
- libintl_ngettext ./.libs/libinternal.a(midnight.o)
-
-Signed-off-by: Andreas Mohr <and@gmx.li>
----
- src/Makefile.am | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -53,7 +53,8 @@ libinternal_la_LIBADD = \
-
- mc_LDADD = \
- libinternal.la \
-- $(top_builddir)/lib/libmc.la
-+ $(top_builddir)/lib/libmc.la \
-+ $(LIBINTL)
-
- if ENABLE_VFS_SMB
- # this is a hack for linking with own samba library in simple way
---- a/src/Makefile.in
-+++ b/src/Makefile.in
-@@ -556,7 +557,7 @@ libinternal_la_LIBADD = \
- viewer/libmcviewer.la \
- $(DIFFLIB) $(EDITLIB) $(SUBSHELLLIB)
-
--mc_LDADD = libinternal.la $(top_builddir)/lib/libmc.la $(am__append_6)
-+mc_LDADD = libinternal.la $(top_builddir)/lib/libmc.la $(LIBINTL) $(am__append_6)
- SRC_mc_conssaver = \
- cons.handler.c consaver/cons.saver.h
diff --git a/app-misc/mc/files/mc-4.8.26-ncurses-mouse.patch b/app-misc/mc/files/mc-4.8.26-ncurses-mouse.patch
new file mode 100644
index 000000000000..bde04c99b86e
--- /dev/null
+++ b/app-misc/mc/files/mc-4.8.26-ncurses-mouse.patch
@@ -0,0 +1,16 @@
+Fix mouse-key input with ncurses6 in terminals without basic X10 mouse
+support, at the cost of breaking it with ncurses5. See discussion in
+https://midnight-commander.org/ticket/4144 .
+
+--- a/lib/tty/key.c
++++ b/lib/tty/key.c
+@@ -2124,8 +2124,7 @@
+ gboolean extended = c == MCKEY_EXTENDED_MOUSE;
+
+ #ifdef KEY_MOUSE
+- extended = extended || (c == KEY_MOUSE && xmouse_seq == NULL
+- && xmouse_extended_seq != NULL);
++ extended = extended || (c == KEY_MOUSE && xmouse_extended_seq != NULL);
+ #endif /* KEY_MOUSE */
+
+ xmouse_get_event (event, extended);
diff --git a/app-misc/mc/files/mc-4.8.29-gentoo-tools.patch b/app-misc/mc/files/mc-4.8.29-gentoo-tools.patch
new file mode 100644
index 000000000000..4c7ccfed942b
--- /dev/null
+++ b/app-misc/mc/files/mc-4.8.29-gentoo-tools.patch
@@ -0,0 +1,11 @@
+--- a/misc/ext.d/video.sh
++++ b/misc/ext.d/video.sh
+@@ -19,7 +19,7 @@
+ elif which mpv_identify.sh >/dev/null 2>&1; then
+ mpv_identify.sh "${MC_EXT_FILENAME}"
+ else
+- echo "Please install either mplayer or mpv to get information for this file"
++ echo "Please install either mplayer or mpv[tools] to get information for this file"
+ fi
+ ;;
+ esac
diff --git a/app-misc/mc/files/mc-4.8.30-fish_fix_broken_national_characters.patch b/app-misc/mc/files/mc-4.8.30-fish_fix_broken_national_characters.patch
new file mode 100644
index 000000000000..193ac7225076
--- /dev/null
+++ b/app-misc/mc/files/mc-4.8.30-fish_fix_broken_national_characters.patch
@@ -0,0 +1,40 @@
+--- a/src/vfs/fish/fish.c
++++ b/src/vfs/fish/fish.c
+@@ -647,7 +647,7 @@ fish_open_archive_int (struct vfs_class *me, struct vfs_s_super *super)
+ /* Set up remote locale to C, otherwise dates cannot be recognized */
+ if (fish_command
+ (me, super, WAIT_REPLY,
+- "LANG=C LC_ALL=C LC_TIME=C; export LANG LC_ALL LC_TIME;\n" "echo '### 200'\n",
++ "LANG=C.UTF-8 LC_ALL=C.UTF-8 LC_TIME=C.UTF-8; export LANG LC_ALL LC_TIME;\n" "echo '### 200'\n",
+ -1) != COMPLETE)
+ ERRNOR (E_PROTO, -1);
+
+--- a/src/vfs/fish/fishdef.h
++++ b/src/vfs/fish/fishdef.h
+@@ -12,7 +12,7 @@
+ /* default 'ls' script */
+ #define FISH_LS_DEF_CONTENT "" \
+ "#LIST /${FISH_FILENAME}\n" \
+-"export LC_TIME=C\n" \
++"export LC_TIME=C.UTF-8\n" \
+ "ls -Qlan \"/${FISH_FILENAME}\" 2>/dev/null | grep '^[^cbt]' | (\n" \
+ "while read p l u g s m d y n; do\n" \
+ " echo \"P$p $u.$g\"\n" \
+@@ -129,7 +129,7 @@
+
+ /* default 'retr' script */
+ #define FISH_GET_DEF_CONTENT "" \
+-"export LC_TIME=C\n" \
++"export LC_TIME=C.UTF-8\n" \
+ "#RETR $FISH_FILENAME\n" \
+ "if dd if=\"/${FISH_FILENAME}\" of=/dev/null bs=1 count=1 2>/dev/null ; then\n" \
+ " ls -ln \"/${FISH_FILENAME}\" 2>/dev/null | (\n" \
+@@ -181,7 +181,7 @@
+
+ /* default 'info' script */
+ #define FISH_INFO_DEF_CONTENT "" \
+-"export LC_TIME=C\n" \
++"export LC_TIME=C.UTF-8\n" \
+ "#FISH_HAVE_HEAD 1\n" \
+ "#FISH_HAVE_SED 2\n" \
+ "#FISH_HAVE_AWK 4\n" \
diff --git a/app-misc/mc/files/mc-4.8.30-mcdiff-segfault.patch b/app-misc/mc/files/mc-4.8.30-mcdiff-segfault.patch
new file mode 100644
index 000000000000..ad752a11816f
--- /dev/null
+++ b/app-misc/mc/files/mc-4.8.30-mcdiff-segfault.patch
@@ -0,0 +1,36 @@
+From dfe3279a365d629ba848f0265108d98d9f12348f Mon Sep 17 00:00:00 2001
+From: Andrew Borodin <aborodin@vmail.ru>
+Date: Sun, 27 Aug 2023 19:32:53 +0300
+Subject: [PATCH] Ticket 4500: mcdiff: segfault when display of line numbers is
+ enabled.
+
+The bug was introduced in 00f84fbf24b5f65381f41c5d6333182bc7921700.
+
+ * (dview_load_options): avoid NULL dereference: don't caclulate the
+ width of line numbers field here because dview->a isn't created yet.
+ * (dview_update): caclulate the width of line numbers field using an
+ actual length of diff lines array.
+
+Signed-off-by: Andrew Borodin <aborodin@vmail.ru>
+--- a/src/diffviewer/ydiff.c
++++ b/src/diffviewer/ydiff.c
+@@ -2366,7 +2366,7 @@ dview_load_options (WDiff * dview)
+ dview->display_symbols = 1;
+ show_numbers = mc_config_get_bool (mc_global.main_config, "DiffView", "show_numbers", FALSE);
+ if (show_numbers)
+- dview->display_numbers = calc_nwidth ((const GArray * const *) dview->a);
++ dview->display_numbers = 1;
+ tab_size = mc_config_get_int (mc_global.main_config, "DiffView", "tab_size", 8);
+ if (tab_size > 0 && tab_size < 9)
+ dview->tab_size = tab_size;
+@@ -2885,6 +2885,10 @@ dview_update (WDiff * dview)
+ if (height < 2)
+ return;
+
++ /* use an actual length of dview->a */
++ if (dview->display_numbers != 0)
++ dview->display_numbers = calc_nwidth ((const GArray * const *) dview->a);
++
+ width1 = dview->half1 + dview->bias;
+ width2 = dview->half2 - dview->bias;
+ if (dview->full)
diff --git a/app-misc/mc/files/mc-4.8.30-musl-tests.patch b/app-misc/mc/files/mc-4.8.30-musl-tests.patch
new file mode 100644
index 000000000000..0e8ea32e2990
--- /dev/null
+++ b/app-misc/mc/files/mc-4.8.30-musl-tests.patch
@@ -0,0 +1,15 @@
+--- a/tests/lib/vfs/path_len.c
++++ b/tests/lib/vfs/path_len.c
+@@ -89,12 +89,6 @@
+ "/тестовый/путь",
+ 26
+ },
+-#ifdef HAVE_CHARSET
+- { /* 3. */
+- "/#enc:KOI8-R/тестовый/путь",
+- 38
+- },
+-#endif /* HAVE_CHARSET */
+ };
+ /* *INDENT-ON* */
+