summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/mouseremote/files/mouseremote-0.90-makefile.patch')
-rw-r--r--app-misc/mouseremote/files/mouseremote-0.90-makefile.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-misc/mouseremote/files/mouseremote-0.90-makefile.patch b/app-misc/mouseremote/files/mouseremote-0.90-makefile.patch
new file mode 100644
index 000000000000..560740c67a2e
--- /dev/null
+++ b/app-misc/mouseremote/files/mouseremote-0.90-makefile.patch
@@ -0,0 +1,20 @@
+--- a/MultiMouse/Makefile
++++ b/MultiMouse/Makefile
+@@ -20,14 +20,13 @@
+ -DMOUSE_FIFO=\"$(FIFO)\"\
+ -DLOCKDIR=\"$(LOCKDIR)\"\
+ -DMAX_MICE=$(MICE)
+-CFLAGS= $(OPTS)\
+- -O2 # -DDEBUG
+-LDLAGS= -O2
++
++OUTPUT_OPTION= $(OPTS) -o $@
+
+ all: $(TARGET)
+
+ multimoused: $(OBJS)
+- $(CC) -o $@ $(OBJS)
++ $(CC) $(LDFLAGS) -o $@ $(OBJS)
+
+ multimouse.1 multimoused.8 multimouse: Makefile
+ sed -e 's|%LOCKDIR%|$(LOCKDIR)|' -e 's|%BINDIR%|$(BINDIR)|'\