summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/neofetch/neofetch-7.1.0-r1.ebuild')
-rw-r--r--app-misc/neofetch/neofetch-7.1.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/neofetch/neofetch-7.1.0-r1.ebuild b/app-misc/neofetch/neofetch-7.1.0-r1.ebuild
new file mode 100644
index 000000000000..766e7a9f7491
--- /dev/null
+++ b/app-misc/neofetch/neofetch-7.1.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature prefix
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ~ppc ppc64 ~riscv ~sparc x86 ~arm64-macos ~x64-macos"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dylanaraps/neofetch.git"
+fi
+
+DESCRIPTION="Simple information system script"
+HOMEPAGE="https://github.com/dylanaraps/neofetch"
+LICENSE="MIT"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-arm-riscv-loongarch-cpu-model-detection.patch
+)
+
+src_prepare() {
+ if use prefix; then
+ # bug #693526
+ hprefixify neofetch
+ sed -e "/has emerge/s:\${br_prefix}:${EPREFIX}:" -i neofetch \
+ || die "Failed to adjust for Prefix"
+ fi
+
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}
+
+pkg_postinst() {
+ optfeature "displaying images" "media-libs/imlib2 www-client/w3m[imlib]"
+ optfeature "gpu detection" sys-apps/pciutils
+ optfeature "thumbnail creation" media-gfx/imagemagick
+ optfeature "wallpaper" media-gfx/feh x11-misc/nitrogen
+ optfeature "window size" x11-misc/xdotool "x11-apps/xwininfo x11-apps/xprop" "x11-apps/xwininfo x11-apps/xdpyinfo"
+}