summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/notary')
-rw-r--r--app-misc/notary/Manifest2
-rw-r--r--app-misc/notary/metadata.xml2
-rw-r--r--app-misc/notary/notary-0.6.1-r1.ebuild46
-rw-r--r--app-misc/notary/notary-0.7.0.ebuild36
4 files changed, 38 insertions, 48 deletions
diff --git a/app-misc/notary/Manifest b/app-misc/notary/Manifest
index ef95fe07f703..d9d54ecd62f3 100644
--- a/app-misc/notary/Manifest
+++ b/app-misc/notary/Manifest
@@ -1 +1 @@
-DIST notary-0.6.1.tar.gz 5741924 BLAKE2B 125e1e09178f090de9d73bb97170737d03c8f43927cf070a2c78e0c5eff3cd56a58aaf703a4ba60aa3e1bd7e22d2ceb0921abaa98e6f871ed1131249e44c622d SHA512 76e223c0c5c59796db924f0e52ea59d2bdbb101a9a059cd70d336928dcac616943d75fc9b8d7703de8609b2f694d2fc5627deb341971dc9401c00974261d57c3
+DIST notary-0.7.0.tar.gz 7146025 BLAKE2B 2aafa82e27eb498d21d09781b54f9a40df57ba23fd4386b5d8fdc0eb09a74b761a1bc3c618ad2403b21e049c4dfb9e75281e949cc8f29474da6903d5fc06ede3 SHA512 8996f4d64fda5db54d460ae8168360fdde86986752b30255ab9cf9cf12d475f88d7ac4f2b0e15d6cb9ee8eff2709306fd0b3d38708ee41caa94862d795ca6a75
diff --git a/app-misc/notary/metadata.xml b/app-misc/notary/metadata.xml
index bd7fe8dd590b..c65037c5f7b8 100644
--- a/app-misc/notary/metadata.xml
+++ b/app-misc/notary/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<upstream>
diff --git a/app-misc/notary/notary-0.6.1-r1.ebuild b/app-misc/notary/notary-0.6.1-r1.ebuild
deleted file mode 100644
index 5def4a774c57..000000000000
--- a/app-misc/notary/notary-0.6.1-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit golang-vcs-snapshot golang-build user
-
-KEYWORDS="~amd64"
-DESCRIPTION="A project that allows anyone to have trust over arbitrary collections of data"
-EGO_PN="github.com/theupdateframework/notary"
-GIT_COMMIT="d6e1431feb32348e0650bf7551ac5cffd01d857b"
-
-HOMEPAGE="https://github.com/theupdateframework/notary"
-SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
-}
-
-src_compile() {
- pushd src/${EGO_PN} || die
- GOPATH=${S} go install -v -tags pkcs11 -ldflags "-w -X ${EGO_PN}/version.GitCommit=${GIT_COMMIT} -X ${EGO_PN}/version.NotaryVersion=${PV}" \
- ${EGO_PN}/cmd/notary-server || die
- GOPATH=${S} go install -v -tags pkcs11 -ldflags "-w -X ${EGO_PN}/version.GitCommit=${GIT_COMMIT} -X ${EGO_PN}/version.NotaryVersion=${PV}" \
- ${EGO_PN}/cmd/notary-signer || die
- GOPATH=${S} go install -v -tags pkcs11 -ldflags "-w -X ${EGO_PN}/version.GitCommit=${GIT_COMMIT} -X ${EGO_PN}/version.NotaryVersion=${PV}" \
- ${EGO_PN}/cmd/notary || die
- popd || die
-}
-
-src_install() {
- dobin bin/${PN}{,-server,-signer}
- pushd src/${EGO_PN} || die
- insinto /var/lib/notary
- doins -r migrations fixtures
- fowners -R ${PN}:${PN} /var/lib/notary
- fperms -R 0600 /var/lib/notary/fixtures/database/
- newinitd "${FILESDIR}"/notary-signer.initd notary-signer
- newconfd "${FILESDIR}"/notary-signer.confd notary-signer
- newinitd "${FILESDIR}"/notary-server.initd notary-server
- newconfd "${FILESDIR}"/notary-server.confd notary-server
-}
diff --git a/app-misc/notary/notary-0.7.0.ebuild b/app-misc/notary/notary-0.7.0.ebuild
new file mode 100644
index 000000000000..4ca8fbf90066
--- /dev/null
+++ b/app-misc/notary/notary-0.7.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=b0b6bfdd
+
+DESCRIPTION="A project that allows anyone to have trust over arbitrary collections of data"
+HOMEPAGE="https://github.com/notaryproject/notary"
+SRC_URI="https://github.com/notaryproject/notary/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ acct-group/notary
+ acct-user/notary
+"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ emake GITCOMMIT=${GIT_COMMIT} NOTARY_VERSION=${PV} binaries
+}
+
+src_install() {
+ dobin bin/${PN}{,-server,-signer}
+ insinto /var/lib/notary
+ doins -r migrations fixtures
+ fowners -R ${PN}:${PN} /var/lib/notary
+ fperms -R 0600 /var/lib/notary/fixtures/database/
+ newinitd "${FILESDIR}"/notary-signer.initd notary-signer
+ newconfd "${FILESDIR}"/notary-signer.confd notary-signer
+ newinitd "${FILESDIR}"/notary-server.initd notary-server
+ newconfd "${FILESDIR}"/notary-server.confd notary-server
+}