summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild')
-rw-r--r--app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild b/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild
new file mode 100644
index 000000000000..29925e2a50ea
--- /dev/null
+++ b/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+SRC_URI="https://gitlab.com/OpenRGBDevelopers/OpenRGBVisualMapPlugin/-/archive/release_${PV}/OpenRGBVisualMapPlugin-release_${PV}.tar.bz2"
+S="${WORKDIR}/OpenRGBVisualMapPlugin-release_${PV}"
+KEYWORDS="amd64"
+
+DESCRIPTION="Plugin for OpenRGB to create virtual devices out of multiple real ones"
+HOMEPAGE="https://gitlab.com/OpenRGBDevelopers/OpenRGBVisualMapPlugin"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=app-misc/openrgb-0.8:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-dep.patch"
+)
+
+src_prepare() {
+ default
+ rm -r OpenRGB || die
+ ln -s "${ESYSROOT}/usr/include/OpenRGB" . || die
+ sed -e '/^GIT_/d' -i *.pro || die
+}
+
+src_configure() {
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/OpenRGB/plugins
+ doexe libOpenRGBVisualMapPlugin.so.1.0.0
+}