summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/piper/piper-0.6.ebuild')
-rw-r--r--app-misc/piper/piper-0.6.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-misc/piper/piper-0.6.ebuild b/app-misc/piper/piper-0.6.ebuild
index bc683c50c698..5b9840cc142a 100644
--- a/app-misc/piper/piper-0.6.ebuild
+++ b/app-misc/piper/piper-0.6.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit meson python-single-r1 xdg
-DESCRIPTION="GTK configuration application for libratbag"
+DESCRIPTION="GTK application to configure gaming devices"
HOMEPAGE="https://github.com/libratbag/piper"
SRC_URI="https://github.com/libratbag/piper/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -35,10 +35,10 @@ RDEPEND="
x11-libs/gdk-pixbuf[introspection]
x11-libs/gtk+:3[introspection]
$(python_gen_cond_dep '
+ dev-python/evdev[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
- dev-python/python-evdev[${PYTHON_USEDEP}]
')
"
DEPEND="
@@ -47,6 +47,8 @@ DEPEND="
virtual/libudev
"
+PATCHES=( "${FILESDIR}/${P}-fix-tests.patch" )
+
src_configure() {
python_setup