summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/pipeworks/files/pipeworks-0.4-makefile.patch')
-rw-r--r--app-misc/pipeworks/files/pipeworks-0.4-makefile.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/pipeworks/files/pipeworks-0.4-makefile.patch b/app-misc/pipeworks/files/pipeworks-0.4-makefile.patch
new file mode 100644
index 000000000000..8a52d158b0e4
--- /dev/null
+++ b/app-misc/pipeworks/files/pipeworks-0.4-makefile.patch
@@ -0,0 +1,26 @@
+--- a/Makefile
++++ b/Makefile
+@@ -18,21 +18,11 @@
+ # along with pipeworks; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+-CC= gcc -Wall
++CFLAGS += -Wall
+
+ all: pipeworks
+
+-filesize.o: Makefile filesize.h filesize.c
+- $(CC) -c -o filesize.o filesize.c
+-
+-timemanip.o: Makefile timemanip.h timemanip.c
+- $(CC) -c -o timemanip.o timemanip.c
+-
+-pipeworks.o: Makefile pipeworks.c filesize.h
+- $(CC) -c -o pipeworks.o pipeworks.c
+-
+-pipeworks: pipeworks.o filesize.o timemanip.o
+- $(CC) -o pipeworks pipeworks.o filesize.o timemanip.o
++pipeworks: filesize.o timemanip.o
+
+ clean:
+ rm -f *.o *~ pipeworks