summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/plod/plod-1.9-r3.ebuild')
-rw-r--r--app-misc/plod/plod-1.9-r3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/plod/plod-1.9-r3.ebuild b/app-misc/plod/plod-1.9-r3.ebuild
new file mode 100644
index 000000000000..21263f3367a2
--- /dev/null
+++ b/app-misc/plod/plod-1.9-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Tool to help administrators keep track of daily activities"
+HOMEPAGE="https://deer-run.com/users/hal/"
+SRC_URI="http://www.far2wise.net/plod/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-1+ )"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+BDEPEND="dev-lang/perl"
+
+src_unpack() {
+ default
+
+ # Bug #619934. Change directories first to ensure that "unpack" outputs
+ # to ${S} and not to ${WORKDIR}.
+ cd "${S}" || die
+ unpack "${S}"/${PN}.1.gz
+}
+
+src_prepare() {
+ default
+
+ sed -i -e 's#/usr/local#/usr#' "${PN}" || die
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+
+ insinto /etc
+ doins "${FILESDIR}"/${PN}rc
+
+ dodoc README TODO
+}