summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/race64/race64-1.0.0.ebuild')
-rw-r--r--app-misc/race64/race64-1.0.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/race64/race64-1.0.0.ebuild b/app-misc/race64/race64-1.0.0.ebuild
new file mode 100644
index 000000000000..5c0bf7a9080e
--- /dev/null
+++ b/app-misc/race64/race64-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="High performance base64 encoder and decoder"
+HOMEPAGE="https://github.com/skeeto/race64"
+SRC_URI="https://github.com/skeeto/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="openmp"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_compile() {
+ use openmp && append-flags -fopenmp
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die
+}
+
+src_test() {
+ ./test.sh || die 'test failed'
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}