summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/rdfind/rdfind-1.6.0.ebuild')
-rw-r--r--app-misc/rdfind/rdfind-1.6.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/rdfind/rdfind-1.6.0.ebuild b/app-misc/rdfind/rdfind-1.6.0.ebuild
new file mode 100644
index 000000000000..fb2795b6bf08
--- /dev/null
+++ b/app-misc/rdfind/rdfind-1.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Find duplicate files based on their content"
+HOMEPAGE="https://github.com/pauldreik/rdfind"
+SRC_URI="https://rdfind.pauldreik.se/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="dev-libs/nettle:="
+DEPEND="${RDEPEND}"
+BDEPEND="dev-build/autoconf-archive"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_test() {
+ # Bug 840544
+ local -x SANDBOX_PREDICT="${SANDBOX_PREDICT}"
+ addpredict /
+ default
+}