summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/reptyr')
-rw-r--r--app-misc/reptyr/Manifest3
-rw-r--r--app-misc/reptyr/metadata.xml6
-rw-r--r--app-misc/reptyr/reptyr-0.10.0.ebuild (renamed from app-misc/reptyr/reptyr-0.8.0.ebuild)8
-rw-r--r--app-misc/reptyr/reptyr-0.9.0.ebuild33
4 files changed, 40 insertions, 10 deletions
diff --git a/app-misc/reptyr/Manifest b/app-misc/reptyr/Manifest
index c89832a0568c..86cac7bfd069 100644
--- a/app-misc/reptyr/Manifest
+++ b/app-misc/reptyr/Manifest
@@ -1 +1,2 @@
-DIST reptyr-0.8.0.tar.gz 32239 BLAKE2B eb3d966c06df710ea27a421bceaca0c91e342cb981567eedc9125e5dd2dc937be294dc212ed9b3021d5e5d75e1011fa4a39eaf93c152c24ef7c5098f8edd9018 SHA512 880d899a2b6df3c33909dc70ce0a58f413b2e2eec2e212abc709348345d48294cf2e39f5891ab4b1fa24e69b54effe99c1b8ab03b448bfd7097e20498e7e85dc
+DIST reptyr-0.10.0.tar.gz 33216 BLAKE2B 4dc30f377588ff5ee74460440c1be7067969ce6ec387cb7379b60c2256467a0f2c9f0689387d38ebcccd73d84ed733fc713852b628fc6e4818195482ace64c25 SHA512 5bbf22a93ceb69489c1370d1a80fdf0916cb057346f8d83a8568228622a0e58ed8cfb374bc69e090219b4d69903d2ff400f0bf4ee2f910eb9301492fe69af78c
+DIST reptyr-0.9.0.tar.gz 32589 BLAKE2B 2673128d90f302a5591466314446257b654f727efce24e2c1a68a2f876a7b385905acb5a4648945ce15e90e2419b4aee5a8a88377dd8229f3b130ba5ba858e46 SHA512 a59670449cb597657dbb244228fd4246142190615ce1a6369f11b8c99cb12d8e2bedb4efd7cdc301a4f7c18d29e8799eea8f14d062a8ad7b7c025034cba66ac7
diff --git a/app-misc/reptyr/metadata.xml b/app-misc/reptyr/metadata.xml
index c5eb1454b5dd..dc7b9c5ea52b 100644
--- a/app-misc/reptyr/metadata.xml
+++ b/app-misc/reptyr/metadata.xml
@@ -1,10 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>polynomial-c@gentoo.org</email>
- <name>Lars Wendler</name>
- </maintainer>
<maintainer type="project">
<email>shell-tools@gentoo.org</email>
<name>Gentoo Shell Tools Project</name>
diff --git a/app-misc/reptyr/reptyr-0.8.0.ebuild b/app-misc/reptyr/reptyr-0.10.0.ebuild
index f8a8c99e0201..2b75f965c71a 100644
--- a/app-misc/reptyr/reptyr-0.8.0.ebuild
+++ b/app-misc/reptyr/reptyr-0.10.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit bash-completion-r1 toolchain-funcs flag-o-matic vcs-snapshot
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/nelhage/${PN}/archive/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
RESTRICT="test"
@@ -23,7 +23,7 @@ src_prepare() {
src_compile() {
append-cppflags -D_GNU_SOURCE
- emake CC=$(tc-getCC) CFLAGS="${CFLAGS}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}
src_install() {
diff --git a/app-misc/reptyr/reptyr-0.9.0.ebuild b/app-misc/reptyr/reptyr-0.9.0.ebuild
new file mode 100644
index 000000000000..36b4a0ba132d
--- /dev/null
+++ b/app-misc/reptyr/reptyr-0.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 toolchain-funcs flag-o-matic vcs-snapshot
+
+DESCRIPTION="A utility to attach a running program to a new terminal"
+HOMEPAGE="https://github.com/nelhage/reptyr"
+SRC_URI="https://github.com/nelhage/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ # respect CFLAGS
+ sed -i '/^override/d' Makefile || die
+}
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc ChangeLog NOTES README.md
+ newbashcomp reptyr{.bash,}
+}