summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/rover/rover-1.0.1.ebuild')
-rw-r--r--app-misc/rover/rover-1.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/rover/rover-1.0.1.ebuild b/app-misc/rover/rover-1.0.1.ebuild
new file mode 100644
index 000000000000..ea3173754330
--- /dev/null
+++ b/app-misc/rover/rover-1.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="simple file browser for the terminal"
+HOMEPAGE="https://lecram.github.io/p/rover/"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lecram/${PN}.git"
+else
+ SRC_URI="https://github.com/lecram/${PN}/archive/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="public-domain"
+SLOT="0"
+
+DEPEND="sys-libs/ncurses:=[unicode(+)]"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-install.patch"
+ "${FILESDIR}/${P}-ncurses.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc README.md
+}