summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/screenfetch/screenfetch-9999.ebuild')
-rw-r--r--app-misc/screenfetch/screenfetch-9999.ebuild27
1 files changed, 13 insertions, 14 deletions
diff --git a/app-misc/screenfetch/screenfetch-9999.ebuild b/app-misc/screenfetch/screenfetch-9999.ebuild
index f2c6bb16d7d5..4312905647d7 100644
--- a/app-misc/screenfetch/screenfetch-9999.ebuild
+++ b/app-misc/screenfetch/screenfetch-9999.ebuild
@@ -1,35 +1,34 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit optfeature
+
MY_PN="${PN/f/F}"
DESCRIPTION="Bash Screenshot Information Tool"
HOMEPAGE="https://github.com/KittyKatt/screenFetch"
if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="${HOMEPAGE}.git"
+ EGIT_REPO_URI="https://github.com/KittyKatt/screenFetch.git"
inherit git-r3
else
- KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
- SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~loong ~x86 ~x64-macos"
+ SRC_URI="https://github.com/KittyKatt/screenFetch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${MY_PN}-${PV}"
fi
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
-IUSE="curl X"
-
-DEPEND=""
-RDEPEND="
- curl? ( net-misc/curl )
- X? (
- media-gfx/scrot
- x11-apps/xdpyinfo
- )"
src_install() {
newbin ${PN}-dev ${PN}
einstalldocs
}
+
+pkg_postinst() {
+ optfeature "screenshot taking" media-gfx/scrot
+ optfeature "screenshot uploading" net-misc/curl
+ optfeature "resolution detection" x11-apps/xdpyinfo
+}