summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/screenfetch/screenfetch-9999.ebuild')
-rw-r--r--app-misc/screenfetch/screenfetch-9999.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/app-misc/screenfetch/screenfetch-9999.ebuild b/app-misc/screenfetch/screenfetch-9999.ebuild
index 3010104b14ea..8bb13a276cb6 100644
--- a/app-misc/screenfetch/screenfetch-9999.ebuild
+++ b/app-misc/screenfetch/screenfetch-9999.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit optfeature
+
MY_PN="${PN/f/F}"
DESCRIPTION="Bash Screenshot Information Tool"
@@ -19,17 +21,14 @@ fi
LICENSE="GPL-3+"
SLOT="0"
-IUSE="curl X"
-
-DEPEND=""
-RDEPEND="
- curl? ( net-misc/curl )
- X? (
- media-gfx/scrot
- x11-apps/xdpyinfo
- )"
src_install() {
newbin ${PN}-dev ${PN}
einstalldocs
}
+
+pkg_postinst() {
+ optfeature "screenshot taking" media-gfx/scrot
+ optfeature "screenshot uploading" net-misc/curl
+ optfeature "resolution detection" x11-apps/xdpyinfo
+}