summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/screenfetch')
-rw-r--r--app-misc/screenfetch/screenfetch-3.9.1-r1.ebuild34
-rw-r--r--app-misc/screenfetch/screenfetch-9999.ebuild17
2 files changed, 42 insertions, 9 deletions
diff --git a/app-misc/screenfetch/screenfetch-3.9.1-r1.ebuild b/app-misc/screenfetch/screenfetch-3.9.1-r1.ebuild
new file mode 100644
index 000000000000..8bb13a276cb6
--- /dev/null
+++ b/app-misc/screenfetch/screenfetch-3.9.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature
+
+MY_PN="${PN/f/F}"
+
+DESCRIPTION="Bash Screenshot Information Tool"
+HOMEPAGE="https://github.com/KittyKatt/screenFetch"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/KittyKatt/screenFetch.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+ SRC_URI="https://github.com/KittyKatt/screenFetch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+src_install() {
+ newbin ${PN}-dev ${PN}
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "screenshot taking" media-gfx/scrot
+ optfeature "screenshot uploading" net-misc/curl
+ optfeature "resolution detection" x11-apps/xdpyinfo
+}
diff --git a/app-misc/screenfetch/screenfetch-9999.ebuild b/app-misc/screenfetch/screenfetch-9999.ebuild
index 3010104b14ea..8bb13a276cb6 100644
--- a/app-misc/screenfetch/screenfetch-9999.ebuild
+++ b/app-misc/screenfetch/screenfetch-9999.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit optfeature
+
MY_PN="${PN/f/F}"
DESCRIPTION="Bash Screenshot Information Tool"
@@ -19,17 +21,14 @@ fi
LICENSE="GPL-3+"
SLOT="0"
-IUSE="curl X"
-
-DEPEND=""
-RDEPEND="
- curl? ( net-misc/curl )
- X? (
- media-gfx/scrot
- x11-apps/xdpyinfo
- )"
src_install() {
newbin ${PN}-dev ${PN}
einstalldocs
}
+
+pkg_postinst() {
+ optfeature "screenshot taking" media-gfx/scrot
+ optfeature "screenshot uploading" net-misc/curl
+ optfeature "resolution detection" x11-apps/xdpyinfo
+}