summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-04-08 09:35:54 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-05-27 14:59:14 +0300
commit4deed6c094a92a2ba7b8718f5082bab331741fd6 (patch)
tree17417cbd4b8f04ea3cb40e3f65069442a35aac23 /app-misc/screenfetch
parentapp-misc/screenfetch: Correct LICENSE field (diff)
downloadgentoo-4deed6c094a92a2ba7b8718f5082bab331741fd6.tar.gz
gentoo-4deed6c094a92a2ba7b8718f5082bab331741fd6.tar.bz2
gentoo-4deed6c094a92a2ba7b8718f5082bab331741fd6.zip
app-misc/screenfetch: Use optfeature for runtime deps
Closes: https://bugs.gentoo.org/789594 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/20303 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/screenfetch')
-rw-r--r--app-misc/screenfetch/screenfetch-3.9.1-r1.ebuild34
-rw-r--r--app-misc/screenfetch/screenfetch-9999.ebuild17
2 files changed, 42 insertions, 9 deletions
diff --git a/app-misc/screenfetch/screenfetch-3.9.1-r1.ebuild b/app-misc/screenfetch/screenfetch-3.9.1-r1.ebuild
new file mode 100644
index 000000000000..8bb13a276cb6
--- /dev/null
+++ b/app-misc/screenfetch/screenfetch-3.9.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature
+
+MY_PN="${PN/f/F}"
+
+DESCRIPTION="Bash Screenshot Information Tool"
+HOMEPAGE="https://github.com/KittyKatt/screenFetch"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/KittyKatt/screenFetch.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+ SRC_URI="https://github.com/KittyKatt/screenFetch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+src_install() {
+ newbin ${PN}-dev ${PN}
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "screenshot taking" media-gfx/scrot
+ optfeature "screenshot uploading" net-misc/curl
+ optfeature "resolution detection" x11-apps/xdpyinfo
+}
diff --git a/app-misc/screenfetch/screenfetch-9999.ebuild b/app-misc/screenfetch/screenfetch-9999.ebuild
index 3010104b14ea..8bb13a276cb6 100644
--- a/app-misc/screenfetch/screenfetch-9999.ebuild
+++ b/app-misc/screenfetch/screenfetch-9999.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit optfeature
+
MY_PN="${PN/f/F}"
DESCRIPTION="Bash Screenshot Information Tool"
@@ -19,17 +21,14 @@ fi
LICENSE="GPL-3+"
SLOT="0"
-IUSE="curl X"
-
-DEPEND=""
-RDEPEND="
- curl? ( net-misc/curl )
- X? (
- media-gfx/scrot
- x11-apps/xdpyinfo
- )"
src_install() {
newbin ${PN}-dev ${PN}
einstalldocs
}
+
+pkg_postinst() {
+ optfeature "screenshot taking" media-gfx/scrot
+ optfeature "screenshot uploading" net-misc/curl
+ optfeature "resolution detection" x11-apps/xdpyinfo
+}