summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/selecta/selecta-0.0.7-r1.ebuild')
-rw-r--r--app-misc/selecta/selecta-0.0.7-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-misc/selecta/selecta-0.0.7-r1.ebuild b/app-misc/selecta/selecta-0.0.7-r1.ebuild
new file mode 100644
index 000000000000..014c6d49dd5b
--- /dev/null
+++ b/app-misc/selecta/selecta-0.0.7-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/garybernhardt/selecta"
+else
+ SRC_URI="https://github.com/garybernhardt/selecta/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A fuzzy text selector for files and anything else you need to select"
+HOMEPAGE="https://github.com/garybernhardt/selecta"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-lang/ruby"
+
+src_install() {
+ dobin selecta
+ einstalldocs
+}