summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/siegfried')
-rw-r--r--app-misc/siegfried/Manifest3
-rw-r--r--app-misc/siegfried/metadata.xml11
-rw-r--r--app-misc/siegfried/siegfried-1.11.0.ebuild62
3 files changed, 76 insertions, 0 deletions
diff --git a/app-misc/siegfried/Manifest b/app-misc/siegfried/Manifest
new file mode 100644
index 000000000000..d1355a33d2da
--- /dev/null
+++ b/app-misc/siegfried/Manifest
@@ -0,0 +1,3 @@
+DIST siegfried-1.11.0-data.zip 14626213 BLAKE2B 64bdb75c278c7e21ceb96dea7b96b3ba5f2e361ea9123ab14549832545968519b6504f9d6223cbcaa0f4509d2491a6892e8383dc5891ec0b2dec833506c0b968 SHA512 e7fd2e66158efb4016189f2563af0818ced75ac346985806f2eb7e75a208411dcd1adae226957f486809e9904df3750a932bcf62ecc48c16a5a3c363e64f96ec
+DIST siegfried-1.11.0.deps.tar.xz 12660688 BLAKE2B c894faa87fbc8d1a662e0336d59283b70130875b17d82078a630ad663a340efc02d5a392b55e33c16d7f48a1db39f670fcce8d4a69192b4d195eb33229de2b85 SHA512 a7eefd2d9a6743ca0bbd6e8dee59025b0153570729c630606bdfd9239ed7eb40d65d64107da19959d2b6eab31fa59ef5891750788292323dc5aa75eae09682e2
+DIST siegfried-1.11.0.gh.tar.gz 14122315 BLAKE2B 262b73b32d08a2c65cf758321da8c6c7520fddad006f6562b5356282ae25dcca253ce18b73ff11313ff7103b28ae4262ca7aa50437e2ceefe706ce668aaddaac SHA512 fc7b3f42da7a78cc66f9e71586220acefac8986d645aaf0ba6138a46fc3bf125e76a954c95fec74ac6d369b9bdb16090777fe36eadbf4f6ac994623b3529e723
diff --git a/app-misc/siegfried/metadata.xml b/app-misc/siegfried/metadata.xml
new file mode 100644
index 000000000000..deee7035f1c8
--- /dev/null
+++ b/app-misc/siegfried/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">richardlehane/siegfried</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/siegfried/siegfried-1.11.0.ebuild b/app-misc/siegfried/siegfried-1.11.0.ebuild
new file mode 100644
index 000000000000..5b0297eaee87
--- /dev/null
+++ b/app-misc/siegfried/siegfried-1.11.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Signature-based file format identification"
+HOMEPAGE="
+ https://www.itforarchivists.com/siegfried/
+ https://github.com/richardlehane/siegfried/
+"
+SRC_URI="
+ https://github.com/richardlehane/siegfried/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://github.com/richardlehane/siegfried/releases/download/v${PV}/data_1-11-0.zip
+ -> ${P}-data.zip
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/${P}.deps.tar.xz
+ "
+fi
+
+LICENSE="Apache-2.0"
+# vendored deps
+LICENSE+=" BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ !app-misc/dfshow
+"
+
+src_compile() {
+ go build -v -work -x "${S}"/cmd/roy || die
+ go build -v -work -x "${S}"/cmd/sf || die
+}
+
+src_test() {
+ cp "${WORKDIR}/siegfried/fddXML.zip" cmd/roy/data || die
+ go test -v "${S}"/cmd/roy || die
+ go test -v "${S}"/cmd/sf || die
+}
+
+src_install() {
+ dobin roy sf
+ insinto /usr/share/siegfried
+ doins "${WORKDIR}/siegfried/default.sig"
+ newenvd - 99siegfried <<-EOF
+ SIEGFRIED_HOME="${EPREFIX}/usr/share/siegfried"
+ EOF
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "We use SIEGFRIED_HOME environment variable to point Siegfried"
+ elog "to the signature file. Please source /etc/profile to make it"
+ elog "work. If you would like to use another home directory, check"
+ elog "the -home option."
+ fi
+}