summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/sphinx/sphinx-2.2.11-r5.ebuild')
-rw-r--r--app-misc/sphinx/sphinx-2.2.11-r5.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/app-misc/sphinx/sphinx-2.2.11-r5.ebuild b/app-misc/sphinx/sphinx-2.2.11-r5.ebuild
index 66f738edfe48..cd7ae1b4fc4a 100644
--- a/app-misc/sphinx/sphinx-2.2.11-r5.ebuild
+++ b/app-misc/sphinx/sphinx-2.2.11-r5.ebuild
@@ -1,20 +1,20 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
#MY_P=${P/_/-}
MY_P=${P}-release
DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
-HOMEPAGE="http://www.sphinxsearch.com/"
-SRC_URI="http://sphinxsearch.com/files/${MY_P}.tar.gz"
+HOMEPAGE="https://sphinxsearch.com/"
+SRC_URI="https://sphinxsearch.com/files/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris"
+KEYWORDS="amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
IUSE="debug +id64 mariadb mysql odbc postgres stemmer syslog xml"
REQUIRED_USE="mysql? ( !mariadb ) mariadb? ( !mysql )"
@@ -58,6 +58,13 @@ src_prepare() {
}
src_configure() {
+ # bug #854738
+ append-flags -fno-strict-aliasing
+ filter-lto
+ # This code is no longer maintained and not compatible with modern C/C++ standards, bug #880923
+ append-cflags -std=gnu89
+ append-cxxflags -std=c++11
+
# fix libiconv detection
use !elibc_glibc && export ac_cv_search_iconv=-liconv