summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/srm/srm-1.2.15.ebuild')
-rw-r--r--app-misc/srm/srm-1.2.15.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/app-misc/srm/srm-1.2.15.ebuild b/app-misc/srm/srm-1.2.15.ebuild
index a086636c2048..f1d54f01b4e2 100644
--- a/app-misc/srm/srm-1.2.15.ebuild
+++ b/app-misc/srm/srm-1.2.15.ebuild
@@ -1,36 +1,39 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit autotools epatch
+inherit autotools flag-o-matic
DESCRIPTION="A command-line compatible rm which destroys file contents before unlinking"
HOMEPAGE="https://sourceforge.net/projects/srm/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 x86"
IUSE="debug"
-DEPEND="!app-misc/secure-delete
- sys-kernel/linux-headers
-"
+DEPEND="sys-kernel/linux-headers"
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.15-cflags.patch
+ "${FILESDIR}"/${PN}-1.2.15-musl.patch
+)
src_prepare() {
- epatch "${FILESDIR}/${PN}-1.2.15-cflags.patch"
+ default
eautoreconf
}
src_configure() {
+ # enable the sighandler_t decl on glibc and musl
+ append-cppflags -D_GNU_SOURCE
econf $(use_enable debug)
}
pkg_postinst() {
ewarn "Please note that srm will not work as expected with any journaled file"
ewarn "system (e.g., reiserfs, ext3)."
- ewarn "See: ${EROOT%/}/usr/share/doc/${PF}/README"
+ ewarn "See: ${EROOT}/usr/share/doc/${PF}/README"
}