summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/task/files')
-rw-r--r--app-misc/task/files/0001-TW-1778-Unicode-strings-are-truncated-in-task-descri.patch23
-rw-r--r--app-misc/task/files/task-2.5.1-clang-build-system.patch17
2 files changed, 0 insertions, 40 deletions
diff --git a/app-misc/task/files/0001-TW-1778-Unicode-strings-are-truncated-in-task-descri.patch b/app-misc/task/files/0001-TW-1778-Unicode-strings-are-truncated-in-task-descri.patch
deleted file mode 100644
index 6ff8ac22e21a..000000000000
--- a/app-misc/task/files/0001-TW-1778-Unicode-strings-are-truncated-in-task-descri.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From d025f3deb6349f56a7fc49551e819cfe13f97917 Mon Sep 17 00:00:00 2001
-From: Paul Beckingham <paul@beckingham.net>
-Date: Wed, 31 Aug 2016 17:48:45 -0400
-Subject: [PATCH] TW-1778: Unicode strings are truncated in task description
-
-- Thanks to Andrew, bjonnh, OKOMPer, Vladimir.
----
-diff --git a/src/text.cpp b/src/text.cpp
-index f5e3496b..bc8353f7 100644
---- a/src/text.cpp
-+++ b/src/text.cpp
-@@ -248,7 +248,7 @@ bool extractLine (
- // Premature EOL.
- if (character == '\n')
- {
-- line = text.substr (offset, line_length);
-+ line = text.substr (offset, prior_cursor - offset);
- offset = cursor;
- return true;
- }
---
-2.11.0
-
diff --git a/app-misc/task/files/task-2.5.1-clang-build-system.patch b/app-misc/task/files/task-2.5.1-clang-build-system.patch
deleted file mode 100644
index e138134fcd9a..000000000000
--- a/app-misc/task/files/task-2.5.1-clang-build-system.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Do not force the use of libc++ when compiling with Clang
-Fix by David Denoncin
-https://bugs.gentoo.org/729560
-
---- a/CMakeLists.txt 2020-08-09 14:04:40.095904996 -0000
-+++ b/CMakeLists.txt 2020-08-09 14:04:59.449238208 -0000
-@@ -43,10 +43,6 @@
- message (FATAL_ERROR "C++11 support missing. Try upgrading your C++ compiler. If you have a good reason for using an outdated compiler, please let us know at support@taskwarrior.org.")
- endif (_HAS_CXX11)
-
--if (${CMAKE_CXX_COMPILER_ID} STREQUAL "Clang")
-- set (_CXX11_FLAGS "${_CXX11_FLAGS} -stdlib=libc++")
--endif (${CMAKE_CXX_COMPILER_ID} STREQUAL "Clang")
--
- if (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
- set (LINUX true)
- elseif (${CMAKE_SYSTEM_NAME} MATCHES "Darwin")