summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/timew-report/timew-report-1.4.0.ebuild')
-rw-r--r--app-misc/timew-report/timew-report-1.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/timew-report/timew-report-1.4.0.ebuild b/app-misc/timew-report/timew-report-1.4.0.ebuild
new file mode 100644
index 000000000000..b1f916e049b9
--- /dev/null
+++ b/app-misc/timew-report/timew-report-1.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..10} )
+inherit distutils-r1
+
+DESCRIPTION="An interface for Timewarrior report data"
+HOMEPAGE="https://github.com/lauft/timew-report"
+SRC_URI="https://github.com/lauft/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="${PYTHON_DEPS}
+ app-misc/timew"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/deprecation[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-3.0.3[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests pytest