summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/timew')
-rw-r--r--app-misc/timew/Manifest3
-rw-r--r--app-misc/timew/metadata.xml20
-rw-r--r--app-misc/timew/timew-1.0.0.ebuild25
-rw-r--r--app-misc/timew/timew-1.1.1.ebuild25
-rw-r--r--app-misc/timew/timew-1.4.3-r1.ebuild45
5 files changed, 62 insertions, 56 deletions
diff --git a/app-misc/timew/Manifest b/app-misc/timew/Manifest
index c27519ec95fe..c4d13de3b458 100644
--- a/app-misc/timew/Manifest
+++ b/app-misc/timew/Manifest
@@ -1,2 +1 @@
-DIST timew-1.0.0.tar.gz 140539 BLAKE2B 486c1e99a587597a040e3fb45c15602e56798b5a13ce3f47fb8d73b3995ee270ef2601e49dc4efe3023d1179a111b55c50c92a3feece87d9bad6a26123dc9008 SHA512 0539ff93b2375c154d126c39aa84f21b57b62f51c220c80b2e323a4d6aefd2eda6f87c04112e096222102b019ee3683a78b9ee9d6fbf6736d4a34c529f6152f5
-DIST timew-1.1.1.tar.gz 166484 BLAKE2B 64b8560220550299c76207873184252b1100d146ac745e46f38790a90294c59e5da95852836433f1d5213a2f1272063a534c20b2963a88fbaa1bcb888e40b70b SHA512 d262227d6dc99994599252c9fc55d32e4caac9d5ff1f223b8637005ed9f4f7fa238bd5cb7392c8e42a468f6246a7afad9b6fdb02af636e53d3bd813cfc3ee110
+DIST timew-1.4.3.tar.gz 3188726 BLAKE2B ded92b2ba801023e7f6bc59c0fc17ce069c8279ee92f39280c50dabec0a2425b8612f73edf7842abdbb0b21772244eda325512070c091f32d17ff69cfcd844fa SHA512 89c98ad19d3a5ab5d4e02819d79e553cca4e93da99ec02bbf845b96b421cd084f6786de160e90c97854b50da49448472e9a4c7d23e75c8a93ecd67dda768b24a
diff --git a/app-misc/timew/metadata.xml b/app-misc/timew/metadata.xml
index 674f5ad944f3..e576c1bb5154 100644
--- a/app-misc/timew/metadata.xml
+++ b/app-misc/timew/metadata.xml
@@ -1,8 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>aidecoe@gentoo.org</email>
- <name>Amadeusz Żołnowski</name>
+ <maintainer type="person" proxied="yes">
+ <email>gentoo@denoncin.fr</email>
+ <name>David Denoncin</name>
</maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Timewarrior is a time tracking utility that offers simple
+ stopwatch features as well as sophisticated calendar-based
+ backfill, along with flexible reporting.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">GothenburgBitFactory/timewarrior</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-misc/timew/timew-1.0.0.ebuild b/app-misc/timew/timew-1.0.0.ebuild
deleted file mode 100644
index b17148ed009a..000000000000
--- a/app-misc/timew/timew-1.0.0.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Tracks your time from the command line, and generates reports"
-HOMEPAGE="https://taskwarrior.org/news/news.20160821.html"
-SRC_URI="https://taskwarrior.org/download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-src_configure() {
- mycmakeargs=(
- -DTIMEW_DOCDIR=share/doc/${PF}
- )
- cmake-utils_src_configure
-}
diff --git a/app-misc/timew/timew-1.1.1.ebuild b/app-misc/timew/timew-1.1.1.ebuild
deleted file mode 100644
index 751d9bdd68d9..000000000000
--- a/app-misc/timew/timew-1.1.1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Tracks your time from the command line, and generates reports"
-HOMEPAGE="https://taskwarrior.org/news/news.20160821.html"
-SRC_URI="https://taskwarrior.org/download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-src_configure() {
- mycmakeargs=(
- -DTIMEW_DOCDIR=share/doc/${PF}
- )
- cmake-utils_src_configure
-}
diff --git a/app-misc/timew/timew-1.4.3-r1.ebuild b/app-misc/timew/timew-1.4.3-r1.ebuild
new file mode 100644
index 000000000000..697045ab4185
--- /dev/null
+++ b/app-misc/timew/timew-1.4.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Tracks your time from the command line, and generates reports"
+HOMEPAGE="https://timewarrior.net"
+SRC_URI="https://github.com/GothenburgBitFactory/timewarrior/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+src_configure() {
+ local mycmakeargs=(
+ -DTIMEW_DOCDIR=share/doc/${PF}
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${WORKDIR}"/"${P}"_build || die
+
+ eninja test
+}
+
+src_install() {
+ cmake_src_install
+
+ dodoc -r ext
+ docompress -x /usr/share/doc/${PF}/ext/{on-modify.timewarrior,README}
+
+ doman doc/man1/*.1
+ doman doc/man7/*.7
+}
+
+pkg_postinst() {
+ elog "To integrate timewarrior with taskwarrior, issue the following commands:"
+ elog "cp /usr/share/doc/${PF}/ext/on-modify.timewarrior ~/.task/hooks/"
+ elog "chmod +x ~/.task/hooks/on-modify.timewarrior"
+ elog "see https://timewarrior.net/docs/taskwarrior.html"
+}