summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch')
-rw-r--r--app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch b/app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch
new file mode 100644
index 000000000000..6fbda6197eef
--- /dev/null
+++ b/app-misc/tmate/files/tmate-2.4.0-msgpack-6.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/903657
+https://github.com/tmate-io/tmate/pull/281
+--- a/configure.ac
++++ b/configure.ac
+@@ -207,7 +207,20 @@ PKG_CHECK_MODULES(
+ LIBS="$MSGPACK_LIBS $LIBS"
+ found_msgpack=yes
+ ],
+- found_msgpack=no
++ [
++ found_msgpack=no
++ # msgpack.pc was renamed to msgpack-c.pc in 6.0.0.
++ PKG_CHECK_MODULES(
++ MSGPACKC,
++ msgpack-c >= 1.1.0,
++ [
++ CPPFLAGS="$MSGPACKC_CFLAGS $CPPFLAGS"
++ LIBS="$MSGPACKC_LIBS $LIBS"
++ found_msgpack=yes
++ ],
++ found_msgpack=no
++ )
++ ]
+ )
+ if test "x$found_msgpack" = xno; then
+ AC_MSG_ERROR("msgpack >= 1.1.0 not found")