summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-3.7.0.ebuild')
-rw-r--r--app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-3.7.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-3.7.0.ebuild b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-3.7.0.ebuild
new file mode 100644
index 000000000000..03f1b370a747
--- /dev/null
+++ b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-3.7.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/thewtex/tmux-mem-cpu-load.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/thewtex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 arm64 ppc64 ~riscv x86"
+fi
+
+DESCRIPTION="CPU, RAM memory, and load monitor for use with tmux"
+HOMEPAGE="https://github.com/thewtex/tmux-mem-cpu-load"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DOCS=( AUTHORS README.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.7.0-gcc13.patch
+)