summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tmuxp')
-rw-r--r--app-misc/tmuxp/Manifest5
-rw-r--r--app-misc/tmuxp/metadata.xml5
-rw-r--r--app-misc/tmuxp/tmuxp-1.27.0.ebuild42
-rw-r--r--app-misc/tmuxp/tmuxp-1.43.0.ebuild50
-rw-r--r--app-misc/tmuxp/tmuxp-1.45.0.ebuild51
-rw-r--r--app-misc/tmuxp/tmuxp-1.46.0.ebuild51
-rw-r--r--app-misc/tmuxp/tmuxp-1.5.3.ebuild35
7 files changed, 202 insertions, 37 deletions
diff --git a/app-misc/tmuxp/Manifest b/app-misc/tmuxp/Manifest
index 0487122df719..42b3398e85db 100644
--- a/app-misc/tmuxp/Manifest
+++ b/app-misc/tmuxp/Manifest
@@ -1 +1,4 @@
-DIST tmuxp-1.5.3.tar.gz 71095 BLAKE2B 37c62eb9d334e5cca47cb4687403ad73cfffa57919770d754fb595dc26f76d248001e62e82eb7246104b74e752701ce57fa56cc78e8eeec8dc49e1522fc6b72c SHA512 9d803e715b1b75aec8940996db579ef545f5d291e64c7d4551930ec5ad683d8a5f737cc22328f0d528e709da6f613c8b3451637ec3e93ac7e9d34aea64faa0e0
+DIST tmuxp-1.27.0.tar.gz 862056 BLAKE2B baad339bc59498d26911507f29de38d55991515e03123edc8dca10159fed1492c1ffe37cf45d6d04ffc73134e0ee312c0ace2ffc53ba9cae258239746169e416 SHA512 a9c450c40a40c284c609011d5e47b12ed1a9b1d5c4036b887df7fd75a3bb6263847c459a7e61fc9dcdb463a3ac20de6ac9038b1559369a5f36641ab0baee755d
+DIST tmuxp-1.43.0.tar.gz 869217 BLAKE2B ebaa230723288a37334ee55c9b615610d66aacc5b01d6bf70576de38e9aa1ecc29a7d26299b55880e9ede403855304de080ddec6a16798a269d6bb8d4629498c SHA512 2dec0c941e919258fd884374fe89cf8e558483a50d53a4c6e3148f7639057aa365a959c062ea6929301dcd893b8a6794c002102f030d77fb904eeaa31ec30edd
+DIST tmuxp-1.45.0.tar.gz 869918 BLAKE2B e0f402ec8add4119e3d49b774e0dca0879a54f2f7d3b492979d7e46652ae07bba005c0a5d4784049d8a6c91c83ebf0346aac959ef730f35c63b8fba12459f680 SHA512 426d58c24330f184205a3f6ecbfc0e6871b8372ed882847272a336283f5e02f3461da0e01b0c47c8800a757486fd15f22b02f7175bdd128d5a7aab11a25080b7
+DIST tmuxp-1.46.0.tar.gz 870062 BLAKE2B b8c450e186097584e4f67de6375acd898b02826ad2a7c758cf0a502c7b60c5dad7ae537df8bcc18310ec6c20cd52700d5d87d336e23de4a786c607eb57ffe5f3 SHA512 1e2fa9b20ade766c7bcbec5b3b430c118cfa27b00e808241d0daf6720351d35863000f22ff052bf0f9f38a63e21813814591312ab0c5af14488a6546af5440ed
diff --git a/app-misc/tmuxp/metadata.xml b/app-misc/tmuxp/metadata.xml
index 56cae167d372..bba2b912e2f9 100644
--- a/app-misc/tmuxp/metadata.xml
+++ b/app-misc/tmuxp/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>chutzpah@gentoo.org</email>
<name>Patrick McLean</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">tmux-python/tmuxp</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-misc/tmuxp/tmuxp-1.27.0.ebuild b/app-misc/tmuxp/tmuxp-1.27.0.ebuild
new file mode 100644
index 000000000000..e1e8c9e1a030
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.27.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ =dev-python/libtmux-0.21.0*[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+EPYTEST_DESELECT=(
+ # test doesn't get along with sandbox
+ "tests/cli/test_load.py::test_load_zsh_autotitle_warning"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ SHELL="/bin/bash" epytest tests
+}
diff --git a/app-misc/tmuxp/tmuxp-1.43.0.ebuild b/app-misc/tmuxp/tmuxp-1.43.0.ebuild
new file mode 100644
index 000000000000..098741bc50f2
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.43.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ =dev-python/libtmux-0.35*[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/typing-extensions-4.0.1[${PYTHON_USEDEP}]' 3.{9..10})
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+EPYTEST_DESELECT=(
+ # test doesn't get along with sandbox
+ "tests/cli/test_load.py::test_load_zsh_autotitle_warning"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -r -e 's:libtmux = "~[0-9.]+":libtmux = "~0.30":' \
+ -i pyproject.toml || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ SHELL="/bin/bash" epytest tests
+}
diff --git a/app-misc/tmuxp/tmuxp-1.45.0.ebuild b/app-misc/tmuxp/tmuxp-1.45.0.ebuild
new file mode 100644
index 000000000000..b77d79f89706
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.45.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ =dev-python/libtmux-0.36*[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6.2.5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.14.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/typing-extensions-4.0.1[${PYTHON_USEDEP}]' 3.{9..10})
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+EPYTEST_DESELECT=(
+ # test doesn't get along with sandbox
+ "tests/cli/test_load.py::test_load_zsh_autotitle_warning"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -r -e 's:libtmux = "~[0-9.]+":libtmux = "~0.30":' \
+ -i pyproject.toml || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ SHELL="/bin/bash" epytest tests
+}
diff --git a/app-misc/tmuxp/tmuxp-1.46.0.ebuild b/app-misc/tmuxp/tmuxp-1.46.0.ebuild
new file mode 100644
index 000000000000..b77d79f89706
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.46.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ =dev-python/libtmux-0.36*[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6.2.5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.14.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/typing-extensions-4.0.1[${PYTHON_USEDEP}]' 3.{9..10})
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+EPYTEST_DESELECT=(
+ # test doesn't get along with sandbox
+ "tests/cli/test_load.py::test_load_zsh_autotitle_warning"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -r -e 's:libtmux = "~[0-9.]+":libtmux = "~0.30":' \
+ -i pyproject.toml || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ SHELL="/bin/bash" epytest tests
+}
diff --git a/app-misc/tmuxp/tmuxp-1.5.3.ebuild b/app-misc/tmuxp/tmuxp-1.5.3.ebuild
deleted file mode 100644
index c29c3a629500..000000000000
--- a/app-misc/tmuxp/tmuxp-1.5.3.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 python3_7 )
-inherit distutils-r1
-
-DESCRIPTION="tmux session manager. built on libtmux"
-HOMEPAGE="https://tmuxp.git-pull.com"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="test? (
- >=dev-python/pytest-4.1.1[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- )"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${BDEPEND}
- dev-python/kaptan[${PYTHON_USEDEP}]
- dev-python/libtmux[${PYTHON_USEDEP}]
- >=dev-python/click-7.0[${PYTHON_USEDEP}]
- >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]"
-
-# tests currently failing, reported upstream
-# https://github.com/tmux-python/tmuxp/issues/486
-RESTRICT="test"
-
-python_test() {
- SHELL="/bin/bash" py.test -v || die
-}