summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tpipe/files/tpipe-1.6-makefile.patch')
-rw-r--r--app-misc/tpipe/files/tpipe-1.6-makefile.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/tpipe/files/tpipe-1.6-makefile.patch b/app-misc/tpipe/files/tpipe-1.6-makefile.patch
new file mode 100644
index 000000000000..7ec3566b107f
--- /dev/null
+++ b/app-misc/tpipe/files/tpipe-1.6-makefile.patch
@@ -0,0 +1,32 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,27 +1,16 @@
+ # Change values of variables to adapt.
+-CC = gcc
+ PRG1 = tpipe
+ OBJS1 = $(PRG1).o
+ PRG2 = tap
+ OBJS2 =$(PRG2).o
+-OPTFLAGS= -ansi -pedantic -O4
+-CFLAGS = -Wall $(OPTFLAGS)
+-LDFLAGS = -L.
++OPTFLAGS= -pedantic
++CFLAGS += -Wall $(OPTFLAGS)
+ PREFIX = /usr/local
+ BINDIR = $(PREFIX)/bin
+ MANDIR = $(PREFIX)/man/man1
+
+ all: $(PRG1) $(PRG2)
+
+-.c.o:
+- $(CC) -c $(CFLAGS) -o $@ $<
+-
+-$(PRG1): $(OBJS1)
+- $(CC) $(CFLAGS) -o $(PRG1) $(OBJS1) $(LDFLAGS) $(LIBS)
+-
+-$(PRG2): $(OBJS2)
+- $(CC) $(CFLAGS) -o $(PRG2) $(OBJS2) $(LDFLAGS) $(LIBS)
+-
+ clean:
+ rm -f *~ *.o $(PRG1) $(PRG2)
+