summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tpipe/tpipe-1.6-r2.ebuild')
-rw-r--r--app-misc/tpipe/tpipe-1.6-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/tpipe/tpipe-1.6-r2.ebuild b/app-misc/tpipe/tpipe-1.6-r2.ebuild
new file mode 100644
index 000000000000..144e1e166857
--- /dev/null
+++ b/app-misc/tpipe/tpipe-1.6-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Command to duplicate standard input to more than one program"
+HOMEPAGE="http://www.eurogaran.com/downloads/tpipe"
+SRC_URI="http://www.eurogaran.com/downloads/tpipe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~arm64-macos ~x64-macos"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin tpipe
+ einstalldocs
+ doman tpipe.1
+}