summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/vifm/vifm-9999.ebuild')
-rw-r--r--app-misc/vifm/vifm-9999.ebuild34
1 files changed, 24 insertions, 10 deletions
diff --git a/app-misc/vifm/vifm-9999.ebuild b/app-misc/vifm/vifm-9999.ebuild
index 327c50b20c44..760751eb0f82 100644
--- a/app-misc/vifm/vifm-9999.ebuild
+++ b/app-misc/vifm/vifm-9999.ebuild
@@ -1,26 +1,37 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit git-r3 autotools vim-doc xdg
+inherit autotools vim-doc xdg
DESCRIPTION="Console file manager with vi(m)-like keybindings"
HOMEPAGE="https://vifm.info/"
-EGIT_REPO_URI="https://github.com/vifm/vifm.git"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/vifm/vifm"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/vifm/vifm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="developer +extended-keys gtk +magic +vim +vim-syntax X"
+IUSE="+extended-keys gtk +magic +vim +vim-syntax X"
DEPEND="
- >=sys-libs/ncurses-5.9-r3:0
+ >=sys-libs/ncurses-5.9-r3:=
magic? ( sys-apps/file )
gtk? ( x11-libs/gtk+:2 )
- X? ( x11-libs/libX11 )"
-RDEPEND="${DEPEND}
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="
+ ${DEPEND}
vim? ( || ( app-editors/vim app-editors/gvim ) )
- vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+"
+# "Either perl or Vim is necessary to generate tags for documentation in Vim's format." from configure
+BDEPEND="|| ( dev-lang/perl app-editors/vim )"
src_prepare() {
default
@@ -28,8 +39,11 @@ src_prepare() {
}
src_configure() {
+ # developer just turns off optimisations and adds -Werror again
+ # bug #855386
econf \
- $(use_enable developer) \
+ --disable-developer \
+ --disable-werror \
$(use_enable extended-keys) \
$(use_with magic libmagic) \
$(use_with gtk) \