summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/vifm')
-rw-r--r--app-misc/vifm/Manifest1
-rw-r--r--app-misc/vifm/metadata.xml6
-rw-r--r--app-misc/vifm/vifm-0.11.ebuild3
-rw-r--r--app-misc/vifm/vifm-0.12.ebuild7
-rw-r--r--app-misc/vifm/vifm-0.13.ebuild95
-rw-r--r--app-misc/vifm/vifm-9999.ebuild34
6 files changed, 129 insertions, 17 deletions
diff --git a/app-misc/vifm/Manifest b/app-misc/vifm/Manifest
index ad487eb528c3..5b8dae320eda 100644
--- a/app-misc/vifm/Manifest
+++ b/app-misc/vifm/Manifest
@@ -1,2 +1,3 @@
DIST vifm-0.11.tar.gz 1525791 BLAKE2B c2aa6d3ddd0304ce1e3a0d1c9ac3218a783bc6dd8eebf7b3346ca262811f63dac75597913ad4883c62680cb77036c2985ca4ce88989a0dd0212dce975d8ec8b8 SHA512 15ace460da6d5f9bb7a016d8bb3f3d9cba47a608da5a39defbf7d09ff9de64c90a63a44264d695fe005f2f6d27ecb07dcec8f4ed5aef15e9d8728b52f1168dbd
DIST vifm-0.12.tar.gz 1913398 BLAKE2B 6a1933e5a70a61402ae52259ee9e03515916e9d6df57285726ec6062257d85966a32173142e730fbc35b48250c585a5e66cadba788e2029e5dcd620544341c4f SHA512 9491b1932535daa0ce6bd33ef955bfaedf995da27f049b36bdb0de9aa87a9a4dd6d2e22c8bf79e343febee16ae0fb87edfa8bde9c2d115b92c768e87bc0a8a7d
+DIST vifm-0.13.tar.gz 2218099 BLAKE2B 99661dd0defcb434abdc397855feac5c6da55a783cf8ad6afe333e208c431b9d10f05928fcf5a9f8e28ed4d602f66414162b14a872ce8881526f679e6e66259a SHA512 bd5e9f84cfb176e220e798dcdfc62e2ae3e89dbebd08cf4cce73eb843b85060c2df05f04f4db994d406baf2e0f90a04f5cb871beaf00fb04174464c81dd85938
diff --git a/app-misc/vifm/metadata.xml b/app-misc/vifm/metadata.xml
index 17007ab8bc96..d48a2ae9eff2 100644
--- a/app-misc/vifm/metadata.xml
+++ b/app-misc/vifm/metadata.xml
@@ -1,10 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>monsieurp@gentoo.org</email>
- <name>Patrice Clement</name>
- </maintainer>
+ <!-- maintainer-needed -->
<longdescription>
Vifm is a ncurses based file manager with vi like keybindings. If you
use vi, vifm gives you complete keyboard control over your files without
@@ -23,6 +20,7 @@
<flag name="vim">Install the vifm vim plugin and vim-compatible documentation</flag>
</use>
<upstream>
+ <remote-id type="github">vifm/vifm</remote-id>
<remote-id type="sourceforge">vifm</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-misc/vifm/vifm-0.11.ebuild b/app-misc/vifm/vifm-0.11.ebuild
index ab6195b7ede0..9927dd8f487f 100644
--- a/app-misc/vifm/vifm-0.11.ebuild
+++ b/app-misc/vifm/vifm-0.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,6 +30,7 @@ src_prepare() {
src_configure() {
econf \
+ --disable-werror \
$(use_enable developer) \
$(use_enable extended-keys) \
$(use_with magic libmagic) \
diff --git a/app-misc/vifm/vifm-0.12.ebuild b/app-misc/vifm/vifm-0.12.ebuild
index 7ad0e2c512ff..0084f374fe4d 100644
--- a/app-misc/vifm/vifm-0.12.ebuild
+++ b/app-misc/vifm/vifm-0.12.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/vifm/vifm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
-IUSE="developer +extended-keys gtk +magic +vim +vim-syntax X"
+IUSE="+extended-keys gtk +magic +vim +vim-syntax X"
DEPEND="
>=sys-libs/ncurses-5.9-r3:0
@@ -30,8 +30,11 @@ src_prepare() {
}
src_configure() {
+ # developer just turns off optimisations and adds -Werror again
+ # bug #855386
econf \
- $(use_enable developer) \
+ --disable-developer \
+ --disable-werror \
$(use_enable extended-keys) \
$(use_with magic libmagic) \
$(use_with gtk) \
diff --git a/app-misc/vifm/vifm-0.13.ebuild b/app-misc/vifm/vifm-0.13.ebuild
new file mode 100644
index 000000000000..ae80765cc747
--- /dev/null
+++ b/app-misc/vifm/vifm-0.13.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools vim-doc xdg
+
+DESCRIPTION="Console file manager with vi(m)-like keybindings"
+HOMEPAGE="https://vifm.info/"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/vifm/vifm"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/vifm/vifm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~arm64 ppc x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+extended-keys gtk +magic +vim +vim-syntax X"
+
+DEPEND="
+ >=sys-libs/ncurses-5.9-r3:=
+ magic? ( sys-apps/file )
+ gtk? ( x11-libs/gtk+:2 )
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="
+ ${DEPEND}
+ vim? ( || ( app-editors/vim app-editors/gvim ) )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+"
+# "Either perl or Vim is necessary to generate tags for documentation in Vim's format." from configure
+BDEPEND="|| ( dev-lang/perl app-editors/vim )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # developer just turns off optimisations and adds -Werror again
+ # bug #855386
+ econf \
+ --disable-developer \
+ --disable-werror \
+ $(use_enable extended-keys) \
+ $(use_with magic libmagic) \
+ $(use_with gtk) \
+ $(use_with X X11)
+}
+
+src_install() {
+ default
+
+ if use vim; then
+ local t
+ for t in app plugin; do
+ insinto /usr/share/vim/vimfiles/"${t}"
+ doins -r data/vim/doc/${t}/${PN}*
+ done
+ fi
+
+ if use vim-syntax; then
+ local t
+ for t in ftdetect ftplugin syntax; do
+ insinto /usr/share/vim/vimfiles/"${t}"
+ doins -r data/vim/${t}/${PN}*
+ done
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ if use vim; then
+ update_vim_helptags
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "You don't need to copy or link any files for"
+ elog " the vim plugin and documentation to work anymore."
+ elog "If you copied any vifm files to ~/.vim/ manually"
+ elog " in earlier vifm versions, please delete them."
+ fi
+ elog
+ elog "To use vim in vifm to view the documentation"
+ elog " edit ~/.vifm/vifmrc and set vimhelp instead of novimhelp"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ use vim && update_vim_helptags
+}
diff --git a/app-misc/vifm/vifm-9999.ebuild b/app-misc/vifm/vifm-9999.ebuild
index 327c50b20c44..760751eb0f82 100644
--- a/app-misc/vifm/vifm-9999.ebuild
+++ b/app-misc/vifm/vifm-9999.ebuild
@@ -1,26 +1,37 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit git-r3 autotools vim-doc xdg
+inherit autotools vim-doc xdg
DESCRIPTION="Console file manager with vi(m)-like keybindings"
HOMEPAGE="https://vifm.info/"
-EGIT_REPO_URI="https://github.com/vifm/vifm.git"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/vifm/vifm"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/vifm/vifm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="developer +extended-keys gtk +magic +vim +vim-syntax X"
+IUSE="+extended-keys gtk +magic +vim +vim-syntax X"
DEPEND="
- >=sys-libs/ncurses-5.9-r3:0
+ >=sys-libs/ncurses-5.9-r3:=
magic? ( sys-apps/file )
gtk? ( x11-libs/gtk+:2 )
- X? ( x11-libs/libX11 )"
-RDEPEND="${DEPEND}
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="
+ ${DEPEND}
vim? ( || ( app-editors/vim app-editors/gvim ) )
- vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+"
+# "Either perl or Vim is necessary to generate tags for documentation in Vim's format." from configure
+BDEPEND="|| ( dev-lang/perl app-editors/vim )"
src_prepare() {
default
@@ -28,8 +39,11 @@ src_prepare() {
}
src_configure() {
+ # developer just turns off optimisations and adds -Werror again
+ # bug #855386
econf \
- $(use_enable developer) \
+ --disable-developer \
+ --disable-werror \
$(use_enable extended-keys) \
$(use_with magic libmagic) \
$(use_with gtk) \