summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/vit/vit-2.3.2.ebuild')
-rw-r--r--app-misc/vit/vit-2.3.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/vit/vit-2.3.2.ebuild b/app-misc/vit/vit-2.3.2.ebuild
new file mode 100644
index 000000000000..d55605c797ec
--- /dev/null
+++ b/app-misc/vit/vit-2.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=yes
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A lightweight, fast, curses-based front end to Taskwarrior"
+HOMEPAGE="
+ https://github.com/vit-project/vit
+ https://pypi.org/project/vit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-misc/task
+ $(python_gen_cond_dep '
+ >=dev-python/tasklib-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/urwid-2.1.2[${PYTHON_USEDEP}]
+ ')
+"
+
+distutils_enable_tests pytest