summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/xmind/xmind-3.7.6_p201801311814.ebuild')
-rw-r--r--app-misc/xmind/xmind-3.7.6_p201801311814.ebuild37
1 files changed, 14 insertions, 23 deletions
diff --git a/app-misc/xmind/xmind-3.7.6_p201801311814.ebuild b/app-misc/xmind/xmind-3.7.6_p201801311814.ebuild
index 12a6a7c49210..9999a65deaac 100644
--- a/app-misc/xmind/xmind-3.7.6_p201801311814.ebuild
+++ b/app-misc/xmind/xmind-3.7.6_p201801311814.ebuild
@@ -1,29 +1,28 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit desktop font gnome2-utils
+MY_P="${PN}-8-update7-linux"
+inherit desktop font optfeature xdg
-MY_PV="8-update7"
-MY_P="${PN}-${MY_PV}-linux"
-
-DESCRIPTION="A brainstorming and mind mapping software tool"
+DESCRIPTION="Brainstorming and mind mapping software tool"
HOMEPAGE="https://www.xmind.net"
SRC_URI="http://dl2.xmind.net/xmind-downloads/${MY_P}.zip
https://dev.gentoo.org/~creffett/distfiles/xmind-icons.tar.xz"
+S="${WORKDIR}"
+
LICENSE="EPL-1.0 LGPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
+BDEPEND="app-arch/unzip"
RDEPEND="
>=virtual/jre-1.8
x11-libs/gtk+:2
"
-S=${WORKDIR}
-
QA_PRESTRIPPED="opt/xmind/XMind/libcairo-swt.so"
QA_FLAGS_IGNORED="
opt/xmind/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.400.v20160518-1444/eclipse_1617.so
@@ -35,12 +34,7 @@ FONT_SUFFIX="ttf"
FONT_S="${S}/fonts"
src_configure() {
- if use amd64; then
- XDIR="XMind_amd64"
- else
- XDIR="XMind_i388"
- fi
- mv "$XDIR" XMind || die
+ mv "XMind_$(usex amd64 amd64 i386)" XMind || die
# force data instance & config area to be at home/.xmind directory
sed \
-e '/-configuration/d' \
@@ -77,16 +71,13 @@ src_install() {
font_src_install
}
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
pkg_postinst() {
- gnome2_icon_cache_update
font_pkg_postinst
- elog "For audio notes support, install media-sound/lame"
+ xdg_pkg_postinst
+ optfeature "audio notes support" media-sound/lame
}
pkg_postrm() {
- gnome2_icon_cache_update
+ font_pkg_postrm
+ xdg_pkg_postrm
}