summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/wyrd/wyrd-1.4.6-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/wyrd/wyrd-1.4.6-r1.ebuild b/app-misc/wyrd/wyrd-1.4.6-r1.ebuild
new file mode 100644
index 000000000000..d772784066ee
--- /dev/null
+++ b/app-misc/wyrd/wyrd-1.4.6-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Text-based front-end to Remind"
+HOMEPAGE="http://pessimization.com/software/wyrd/"
+SRC_URI="http://pessimization.com/software/wyrd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="unicode"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ >=app-misc/remind-03.01
+ dev-ml/camlp4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/ocaml-3.08
+"
+
+src_configure() {
+ econf \
+ $(use_enable unicode utf8)
+}
+
+src_install() {
+ export STRIP_MASK="/usr/bin/wyrd"
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog
+ dohtml doc/manual.html
+}