summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/heimdall/heimdall-9999.ebuild')
-rw-r--r--app-mobilephone/heimdall/heimdall-9999.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/app-mobilephone/heimdall/heimdall-9999.ebuild b/app-mobilephone/heimdall/heimdall-9999.ebuild
index e4026eb23735..69599346a8bb 100644
--- a/app-mobilephone/heimdall/heimdall-9999.ebuild
+++ b/app-mobilephone/heimdall/heimdall-9999.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake udev
if [[ ${PV} != 9999 ]]; then
- SRC_URI="https://github.com/Benjamin-Dobell/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/Heimdall-${PV}"
+ SRC_URI="https://git.sr.ht/~grimler/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~arm64"
+ S="${WORKDIR}/Heimdall-v${PV}"
else
inherit git-r3
- EGIT_REPO_URI="https://github.com/Benjamin-Dobell/Heimdall.git"
+ EGIT_REPO_URI="https://git.sr.ht/~grimler/Heimdall"
fi
DESCRIPTION="Tool suite used to flash firmware onto Samsung devices"
-HOMEPAGE="https://glassechidna.com.au/heimdall/ https://github.com/Benjamin-Dobell/Heimdall"
+HOMEPAGE="https://git.sr.ht/~grimler/Heimdall https://glassechidna.com.au/heimdall/ https://github.com/Benjamin-Dobell/Heimdall"
LICENSE="MIT"
SLOT="0"
@@ -46,3 +46,11 @@ src_install() {
udev_dorules heimdall/60-heimdall.rules
dodoc README.md Linux/README
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}