summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/lyx')
-rw-r--r--app-office/lyx/Manifest4
-rw-r--r--app-office/lyx/files/lyx-2.3.6.1-python.patch50
-rw-r--r--app-office/lyx/files/lyx-2.4.0-fix-hunspell.patch21
-rw-r--r--app-office/lyx/files/lyx-2.4.0-prefer-xdg-open.patch54
-rw-r--r--app-office/lyx/files/lyx-prefer-xdg-open.patch60
-rw-r--r--app-office/lyx/lyx-2.3.6.1.ebuild172
-rw-r--r--app-office/lyx/lyx-2.3.7.ebuild (renamed from app-office/lyx/lyx-2.3.5.2-r2.ebuild)45
-rw-r--r--app-office/lyx/lyx-2.4.0_rc4.ebuild180
-rw-r--r--app-office/lyx/metadata.xml8
9 files changed, 406 insertions, 188 deletions
diff --git a/app-office/lyx/Manifest b/app-office/lyx/Manifest
index e20b033ee952..e21550afef7a 100644
--- a/app-office/lyx/Manifest
+++ b/app-office/lyx/Manifest
@@ -1,2 +1,2 @@
-DIST lyx-2.3.5.2.tar.xz 16139804 BLAKE2B e6ea7b2fbec330bfe31b8f88e0a5cc25ff65991421f99b04e98d26945bba48a95f389e2a7e6023d4c9720d43f80136682eb40ac4be51799f01e038e4b0fad206 SHA512 90c5459ad0a77568d588e05a360482985988382927583b14914d6a23b788756e957d0237c18b9ab0681dfc2ad7aa34d21e97304e3a74d19ef047c38f692fba03
-DIST lyx-2.3.6.1.tar.xz 16242608 BLAKE2B d59c6db79d7760902f93405e3737974fa9c6bd79c5ab4b02010021532903c76a77701f1f99a0838b4379c548f3f37dcdd9eeb492b733c4162162d868d1d92970 SHA512 233f6c54d4a036ad12f33c6705810bfb99747bdbd015550a8a0a9d7b664d3be50a06dc337191b820c42de4407c5f790efa50c706a45fb2260a71f772fb22c872
+DIST lyx-2.3.7-1.tar.xz 16158416 BLAKE2B 6041280ab0cd4dfa3c10e8ae01253ff657b4ac9ffe4cf61a3a2459b7aef152a7daf8ae306a09aaece799b6e7b6b15bc1aff62ab0f5d46508fbd79fd3e0b1c45b SHA512 b8aaefb68993032354fea3c6fd87d6da161395c92b5def4ecf92a7d6873ec59e01cdfb45c51ae1aaa62aa54db8e100b00ff9c2c9e0f1307c2f46860cd8c6eefe
+DIST lyx-2.4.0~RC4.tar.xz 17785100 BLAKE2B 15d3785934045e9e3f39426d7a48ae4b200b64f28dc953b69c9b1b6f7c3e6cfe163aeaaaccbea9bb3b89c321a95f3162bab5869a290e4d4be2658bc39d6b2d46 SHA512 fa131ed3323a273529a59266b693381c0123400b7207733398992c99b424831a2918d019353ee0f2e6cce24b47042039f1abdbfe1ceeb28e56e35da4bf9e8c96
diff --git a/app-office/lyx/files/lyx-2.3.6.1-python.patch b/app-office/lyx/files/lyx-2.3.6.1-python.patch
new file mode 100644
index 000000000000..666d82c06bf8
--- /dev/null
+++ b/app-office/lyx/files/lyx-2.3.6.1-python.patch
@@ -0,0 +1,50 @@
+https://src.fedoraproject.org/rpms/lyx/raw/054d18eb79a8ec3d4480ab4449b3c62b12770d2d/f/lyx-2.3.6-layout2layout.patch
+--- a/lib/scripts/layout2layout.py
++++ b/lib/scripts/layout2layout.py
+@@ -256,7 +256,7 @@
+
+ def trim_bom(line):
+ " Remove byte order mark."
+- if line[0:3] == "\357\273\277":
++ if line[0:3] == b"\357\273\277":
+ return line[3:]
+ else:
+ return line
+@@ -345,8 +345,8 @@
+ # for categories
+ re_Declaration = re.compile(b'^#\\s*\\Declare\\w+Class.*$')
+ re_ExtractCategory = re.compile(b'^(#\\s*\\Declare\\w+Class(?:\\[[^]]*?\\])?){([^(]+?)\\s+\\(([^)]+?)\\)\\s*}\\s*$')
+- ConvDict = {"article": "Articles", "book" : "Books", "letter" : "Letters", "report": "Reports", \
+- "presentation" : "Presentations", "curriculum vitae" : "Curricula Vitae", "handout" : "Handouts"}
++ ConvDict = {b"article": b"Articles", b"book" : b"Books", b"letter" : b"Letters", b"report": b"Reports", \
++ b"presentation" : b"Presentations", b"curriculum vitae" : b"Curricula Vitae", b"handout" : b"Handouts"}
+ # Arguments
+ re_OptArgs = re.compile(b'^(\\s*)OptionalArgs(\\s+)(\\d+)\\D*$', re.IGNORECASE)
+ re_ReqArgs = re.compile(b'^(\\s*)RequiredArgs(\\s+)(\\d+)\\D*$', re.IGNORECASE)
+@@ -485,7 +485,7 @@
+ continue
+ col = match.group(2)
+ if col == "collapsable":
+- lines[i] = match.group(1) + "collapsible"
++ lines[i] = match.group(1) + b"collapsible"
+ i += 1
+ continue
+
+@@ -703,7 +703,7 @@
+ # Insert the required number of arguments at the end of the style definition
+ match = re_End.match(lines[i])
+ if match:
+- newarg = ['']
++ newarg = [b'']
+ # First the optionals (this is the required order pre 2.1)
+ if opts > 0:
+ if opts == 1:
+@@ -1153,7 +1153,7 @@
+ if latextype == b"item_environment" and label.lower() == b"counter_enumi":
+ lines[labeltype_line] = re_LabelType.sub(b'\\1\\2\\3Enumerate', lines[labeltype_line])
+ # Don't add the LabelCounter line later
+- counter = ""
++ counter = b""
+
+ # Replace
+ #
diff --git a/app-office/lyx/files/lyx-2.4.0-fix-hunspell.patch b/app-office/lyx/files/lyx-2.4.0-fix-hunspell.patch
new file mode 100644
index 000000000000..265049b46631
--- /dev/null
+++ b/app-office/lyx/files/lyx-2.4.0-fix-hunspell.patch
@@ -0,0 +1,21 @@
+From: Arthur Zamarin <arthurzam@gentoo.org>
+Date: Fri, 5 Apr 2024 15:40:57 +0300
+Subject: fix find hunspell using pkg-config
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -884,6 +884,14 @@ if(NOT LYX_EXTERNAL_HUNSPELL)
+ message(STATUS " * Hunspell:")
+ message(STATUS " - include: ${HUNSPELL_INCLUDE_DIR}")
+ message(STATUS " - library: ${HUNSPELL_LIBRARY}")
++elseif(LYX_HUNSPELL)
++ find_package(PkgConfig)
++ pkg_check_modules(HUNSPELL hunspell)
++ set(HUNSPELL_INCLUDE_DIR ${HUNSPELL_INCLUDE_DIRS})
++ set(HUNSPELL_LIBRARY ${HUNSPELL_LIBRARIES})
++ message(STATUS " * Hunspell:")
++ message(STATUS " - include: ${HUNSPELL_INCLUDE_DIR}")
++ message(STATUS " - library: ${HUNSPELL_LIBRARY}")
+ endif()
+
+ foreach(_spell "ASPELL" "ENCHANT" "HUNSPELL")
diff --git a/app-office/lyx/files/lyx-2.4.0-prefer-xdg-open.patch b/app-office/lyx/files/lyx-2.4.0-prefer-xdg-open.patch
new file mode 100644
index 000000000000..b5a8ef5ced6b
--- /dev/null
+++ b/app-office/lyx/files/lyx-2.4.0-prefer-xdg-open.patch
@@ -0,0 +1,54 @@
+From: Arthur Zamarin <arthurzam@gentoo.org>
+Date: Fri, 5 Apr 2024 16:05:46 +0300
+Add xdg-open as the first choice whenever this seems to be useful
+
+--- a/lib/configure.py
++++ b/lib/configure.py
+@@ -716,7 +716,7 @@ def checkModule(module):
+ return False
+
+
+-texteditors = ['xemacs', 'gvim', 'kedit', 'kwrite', 'kate',
++texteditors = ['xdg-open', 'xemacs', 'gvim', 'kedit', 'kwrite', 'kate',
+ 'nedit', 'gedit', 'geany', 'leafpad', 'mousepad',
+ 'xed', 'notepad', 'WinEdt', 'WinShell', 'PSPad']
+
+@@ -731,7 +731,7 @@ def checkFormatEntries(dtl_tools):
+ checkViewerEditor('a Dia viewer and editor', ['dia'],
+ rc_entry = [r'\Format dia dia DIA "" "%%" "%%" "vector,zipped=native", "application/x-dia-diagram"'])
+ #
+- checkViewerEditor('an OpenDocument drawing viewer and editor', ['libreoffice', 'lodraw', 'ooffice', 'oodraw', 'soffice'],
++ checkViewerEditor('an OpenDocument drawing viewer and editor', ['xdg-open', 'libreoffice', 'lodraw', 'ooffice', 'oodraw', 'soffice'],
+ rc_entry = [r'\Format odg "odg, sxd" "OpenDocument drawing" "" "%%" "%%" "vector,zipped=native" "application/vnd.oasis.opendocument.graphics"'])
+ #
+ checkViewerEditor('a Grace viewer and editor', ['xmgrace'],
+@@ -756,9 +756,9 @@ def checkFormatEntries(dtl_tools):
+ \Format xbm xbm XBM "" "%s" "%s" "" "image/x-xbitmap"
+ \Format xpm xpm XPM "" "%s" "%s" "" "image/x-xpixmap"'''
+ path, iv = checkViewerNoRC('a raster image viewer',
+- ['xv', 'gwenview', 'kview',
++ ['xdg-open', 'xv', 'gwenview', 'kview',
+ 'eog', 'xviewer', 'ristretto', 'gpicview', 'lximage-qt',
+- 'xdg-open', 'gimp-remote', 'gimp'],
++ 'gimp-remote', 'gimp'],
+ rc_entry = [imageformats])
+ path, ie = checkEditorNoRC('a raster image editor',
+ ['gimp-remote', 'gimp'], rc_entry = [imageformats])
+@@ -815,7 +815,7 @@ def checkFormatEntries(dtl_tools):
+ #checkProg('a Postscript interpreter', ['gs'],
+ # rc_entry = [ r'\ps_command "%%"' ])
+ checkViewer('a Postscript previewer',
+- ['kghostview', 'okular', 'qpdfview --unique',
++ ['xdg-open', 'kghostview', 'okular', 'qpdfview --unique',
+ 'evince', 'xreader',
+ 'gv', 'ghostview -swap', 'gsview64', 'gsview32'],
+ rc_entry = [r'''\Format eps eps EPS "" "%%" "" "vector" "image/x-eps"
+@@ -826,7 +826,7 @@ def checkFormatEntries(dtl_tools):
+ # maybe use "bestApplication()" from https://github.com/jleclanche/python-mime
+ # the MIME type is set for pdf6, because that one needs to be autodetectable by libmime
+ checkViewer('a PDF previewer',
+- ['pdfview', 'kpdf', 'okular', 'qpdfview --unique',
++ ['xdg-open', 'pdfview', 'kpdf', 'okular', 'qpdfview --unique',
+ 'evince', 'xreader', 'kghostview', 'xpdf', 'SumatraPDF',
+ 'acrobat', 'acroread', 'mupdf', 'Skim.app',
+ 'gv', 'ghostview', 'AcroRd32', 'gsview64', 'gsview32'],
diff --git a/app-office/lyx/files/lyx-prefer-xdg-open.patch b/app-office/lyx/files/lyx-prefer-xdg-open.patch
new file mode 100644
index 000000000000..5e12f6c2e699
--- /dev/null
+++ b/app-office/lyx/files/lyx-prefer-xdg-open.patch
@@ -0,0 +1,60 @@
+From: "Dr. Tobias Quathamer" <toddy@debian.org>
+Date: Wed, 31 Jan 2018 23:27:37 +0100
+Subject: Prefer xdg-open
+
+Add xdg-open as the first choice whenever this seems to be useful.
+---
+ lib/configure.py | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/lib/configure.py b/lib/configure.py
+index 7fee68d..abc4d53 100644
+--- a/lib/configure.py
++++ b/lib/configure.py
+@@ -657,7 +657,7 @@ def checkFormatEntries(dtl_tools):
+ checkViewerEditor('a Dia viewer and editor', ['dia'],
+ rc_entry = [r'\Format dia dia DIA "" "%%" "%%" "vector,zipped=native", "application/x-dia-diagram"'])
+ #
+- checkViewerEditor('an OpenDocument drawing viewer and editor', ['libreoffice', 'lodraw', 'ooffice', 'oodraw', 'soffice'],
++ checkViewerEditor('an OpenDocument drawing viewer and editor', ['xdg-open', 'libreoffice', 'lodraw', 'ooffice', 'oodraw', 'soffice'],
+ rc_entry = [r'\Format odg "odg, sxd" "OpenDocument drawing" "" "%%" "%%" "vector,zipped=native" "application/vnd.oasis.opendocument.graphics"'])
+ #
+ checkViewerEditor('a Grace viewer and editor', ['xmgrace'],
+@@ -682,16 +682,16 @@ def checkFormatEntries(dtl_tools):
+ \Format xbm xbm XBM "" "%s" "%s" "" "image/x-xbitmap"
+ \Format xpm xpm XPM "" "%s" "%s" "" "image/x-xpixmap"'''
+ path, iv = checkViewerNoRC('a raster image viewer',
+- ['xv', 'gwenview', 'kview',
++ ['xdg-open', 'xv', 'gwenview', 'kview',
+ 'eog', 'xviewer', 'ristretto', 'gpicview', 'lximage-qt',
+- 'xdg-open', 'gimp-remote', 'gimp'],
++ 'gimp-remote', 'gimp'],
+ rc_entry = [imageformats])
+ path, ie = checkEditorNoRC('a raster image editor',
+ ['gimp-remote', 'gimp'], rc_entry = [imageformats])
+ addToRC(imageformats % ((iv, ie)*10))
+ #
+ checkViewerEditor('a text editor',
+- ['xemacs', 'gvim', 'kedit', 'kwrite', 'kate',
++ ['xdg-open', 'xemacs', 'gvim', 'kedit', 'kwrite', 'kate',
+ 'nedit', 'gedit', 'geany', 'leafpad', 'mousepad', 'xed', 'notepad'],
+ rc_entry = [r'''\Format asciichess asc "Plain text (chess output)" "" "" "%%" "" ""
+ \Format docbook sgml DocBook B "" "%%" "document,menu=export" ""
+@@ -745,7 +745,7 @@ def checkFormatEntries(dtl_tools):
+ #checkProg('a Postscript interpreter', ['gs'],
+ # rc_entry = [ r'\ps_command "%%"' ])
+ checkViewer('a Postscript previewer',
+- ['kghostview', 'okular', 'qpdfview --unique',
++ ['xdg-open', 'kghostview', 'okular', 'qpdfview --unique',
+ 'evince', 'xreader',
+ 'gv', 'ghostview -swap', 'gsview64', 'gsview32'],
+ rc_entry = [r'''\Format eps eps EPS "" "%%" "" "vector" "image/x-eps"
+@@ -756,7 +756,7 @@ def checkFormatEntries(dtl_tools):
+ # maybe use "bestApplication()" from https://github.com/jleclanche/python-mime
+ # the MIME type is set for pdf6, because that one needs to be autodetectable by libmime
+ checkViewer('a PDF previewer',
+- ['pdfview', 'kpdf', 'okular', 'qpdfview --unique',
++ ['xdg-open', 'pdfview', 'kpdf', 'okular', 'qpdfview --unique',
+ 'evince', 'xreader', 'kghostview', 'xpdf', 'SumatraPDF',
+ 'acrobat', 'acroread', 'mupdf',
+ 'gv', 'ghostview', 'AcroRd32', 'gsview64', 'gsview32'],
diff --git a/app-office/lyx/lyx-2.3.6.1.ebuild b/app-office/lyx/lyx-2.3.6.1.ebuild
deleted file mode 100644
index 0d37913dc0a8..000000000000
--- a/app-office/lyx/lyx-2.3.6.1.ebuild
+++ /dev/null
@@ -1,172 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-MY_P="${P/_}"
-inherit desktop flag-o-matic font python-single-r1 qmake-utils toolchain-funcs xdg-utils
-
-DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
-HOMEPAGE="https://www.lyx.org/"
-SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/2.3.x/${MY_P}.tar.xz
- ftp://ftp.lyx.org/pub/lyx/devel/lyx-2.3/${MY_P}/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
-IUSE="aspell cups debug dia dot enchant gnumeric html +hunspell +latex monolithic-build nls rcs rtf svg l10n_he"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-BDEPEND="
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-RDEPEND="${PYTHON_DEPS}
- app-text/mythes
- dev-libs/boost:=
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- dev-texlive/texlive-fontsextra
- sys-apps/file
- sys-libs/zlib
- virtual/imagemagick-tools[png,svg?]
- aspell? ( app-text/aspell )
- cups? ( net-print/cups )
- dia? ( app-office/dia )
- dot? ( media-gfx/graphviz )
- enchant? ( app-text/enchant:2 )
- gnumeric? ( app-office/gnumeric )
- html? ( dev-tex/html2latex )
- hunspell? ( app-text/hunspell )
- l10n_he? ( dev-tex/culmus-latex )
- latex? (
- app-text/dvipng
- app-text/ghostscript-gpl
- app-text/ps2eps
- app-text/texlive
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-mathscience
- dev-texlive/texlive-pictures
- dev-texlive/texlive-plaingeneric
- || (
- dev-tex/hevea
- dev-tex/latex2html
- dev-tex/tex4ht[java]
- dev-tex/tth
- )
- )
- rcs? ( dev-vcs/rcs )
- rtf? (
- app-text/unrtf
- dev-tex/html2latex
- dev-tex/latex2rtf
- )
- svg? ( || ( gnome-base/librsvg media-gfx/inkscape ) )
-"
-DEPEND="${RDEPEND}
- dev-qt/qtconcurrent:5
-"
-
-DOCS=( ANNOUNCE NEWS README RELEASE-NOTES UPGRADING )
-
-S="${WORKDIR}/${MY_P}"
-
-FONT_S="${S}/lib/fonts"
-FONT_SUFFIX="ttf"
-
-pkg_setup() {
- python-single-r1_pkg_setup
- font_pkg_setup
-}
-
-src_prepare() {
- default
- sed "s:python -tt:${EPYTHON} -tt:g" -i lib/configure.py || die
-}
-
-src_configure() {
- tc-export CXX
- #bug 221921
- export VARTEXFONTS="${T}"/fonts
-
- econf \
- $(use_with aspell) \
- $(use_enable debug) \
- $(use_with enchant) \
- $(use_with hunspell) \
- $(use_enable monolithic-build) \
- $(use_enable nls) \
- --enable-qt5 \
- --with-qt-dir=$(qt5_get_libdir)/qt5 \
- --disable-stdlib-debug \
- --without-included-boost \
- --with-packaging=posix
-}
-
-src_install() {
- default
-
- if use l10n_he ; then
- echo "\bind_file cua" > "${T}"/hebrew.bind || die
- echo "\bind \"F12\" \"language hebrew\"" >> "${T}"/hebrew.bind || die
-
- insinto /usr/share/lyx/bind
- doins "${T}"/hebrew.bind
- fi
-
- newicon -s 32 "development/Win32/packaging/icons/lyx_32x32.png" ${PN}.png
- doicon -s 48 "lib/images/lyx.png"
- doicon -s scalable "lib/images/lyx.svg"
-
- # fix for bug 91108
- if use latex ; then
- dosym ../../../lyx/tex /usr/share/texmf-site/tex/latex/lyx
- fi
-
- # fonts needed for proper math display, see also bug #15629
- font_src_install
-
- python_fix_shebang "${ED}"/usr/share/${PN}
-
- if use hunspell ; then
- dosym ../myspell /usr/share/lyx/dicts
- dosym ../myspell /usr/share/lyx/thes
- fi
-}
-
-pkg_postinst() {
- font_pkg_postinst
- xdg_icon_cache_update
- xdg_desktop_database_update
-
- # fix for bug 91108
- if use latex ; then
- texhash || die
- fi
-
- # instructions for RTL support. See also bug 168331.
- if use l10n_he || has he ${LINGUAS} || has ar ${LINGUAS} ; then
- elog
- elog "Enabling RTL support in LyX:"
- elog "If you intend to use a RTL language (such as Hebrew or Arabic)"
- elog "You must enable RTL support in LyX. To do so start LyX and go to"
- elog "Tools->Preferences->Language settings->Language"
- elog "and make sure the \"Right-to-left language support\" is checked"
- elog
- fi
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-
- if use latex ; then
- texhash || die
- fi
-}
diff --git a/app-office/lyx/lyx-2.3.5.2-r2.ebuild b/app-office/lyx/lyx-2.3.7.ebuild
index 9291b764f071..29a7b60275a0 100644
--- a/app-office/lyx/lyx-2.3.5.2-r2.ebuild
+++ b/app-office/lyx/lyx-2.3.7.ebuild
@@ -1,25 +1,26 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{9..11} )
MY_P="${P/_}"
-inherit desktop flag-o-matic font python-single-r1 qmake-utils toolchain-funcs xdg-utils
+inherit desktop font optfeature python-single-r1 qmake-utils toolchain-funcs xdg-utils
-DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
+DESCRIPTION="WYSIWYM (What You See Is What You Mean) document processor based on LaTeX"
HOMEPAGE="https://www.lyx.org/"
-SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/2.3.x/${MY_P}.tar.xz
- ftp://ftp.lyx.org/pub/lyx/devel/lyx-2.3/${MY_P}/${MY_P}.tar.xz"
+SRC_URI="http://ftp.lyx.org/pub/lyx/stable/$(ver_cut 1-2).x/${MY_P}-1.tar.xz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86 ~x64-macos"
+KEYWORDS="amd64 ~arm64 ~riscv ~x86 ~x64-macos"
IUSE="aspell cups debug dia dot enchant gnumeric html +hunspell +latex monolithic-build nls rcs rtf svg l10n_he"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# bc needed http://comments.gmane.org/gmane.editors.lyx.devel/137498 and bug #787839
BDEPEND="
+ app-alternatives/bc
virtual/pkgconfig
nls? ( sys-devel/gettext )
"
@@ -31,10 +32,12 @@ RDEPEND="${PYTHON_DEPS}
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
- dev-texlive/texlive-fontsextra
sys-apps/file
sys-libs/zlib
virtual/imagemagick-tools[png,svg?]
+
+ x11-misc/xdg-utils
+
aspell? ( app-text/aspell )
cups? ( net-print/cups )
dia? ( app-office/dia )
@@ -80,6 +83,16 @@ S="${WORKDIR}/${MY_P}"
FONT_S="${S}/lib/fonts"
FONT_SUFFIX="ttf"
+PATCHES=(
+ # Try first with xdg-open before hardcoded commands
+ # Patch from Debian using a similar approach to Fedora
+ "${FILESDIR}"/${PN}-prefer-xdg-open.patch
+
+ # Already part of 2.4.x (from Fedora)
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1965118
+ "${FILESDIR}"/${PN}-2.3.6.1-python.patch
+)
+
pkg_setup() {
python-single-r1_pkg_setup
font_pkg_setup
@@ -87,6 +100,7 @@ pkg_setup() {
src_prepare() {
default
+
sed "s:python -tt:${EPYTHON} -tt:g" -i lib/configure.py || die
}
@@ -140,6 +154,15 @@ src_install() {
fi
}
+pkg_preinst() {
+ # Workaround https://bugs.gentoo.org/907288
+ if has_version "<${CATEGORY}/${PN}-2.3.7"; then
+ ewarn "dev-texlive/texlive-fontsextra is now an optional dependency"
+ ewarn "If you need these fonts, you will need to manually install"
+ ewarn "them."
+ fi
+}
+
pkg_postinst() {
font_pkg_postinst
xdg_icon_cache_update
@@ -160,6 +183,8 @@ pkg_postinst() {
elog "and make sure the \"Right-to-left language support\" is checked"
elog
fi
+
+ optfeature "handling more fonts" dev-texlive/texlive-fontsextra
}
pkg_postrm() {
diff --git a/app-office/lyx/lyx-2.4.0_rc4.ebuild b/app-office/lyx/lyx-2.4.0_rc4.ebuild
new file mode 100644
index 000000000000..f40e3e2a9aec
--- /dev/null
+++ b/app-office/lyx/lyx-2.4.0_rc4.ebuild
@@ -0,0 +1,180 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit desktop font optfeature python-single-r1 cmake xdg
+
+DESCRIPTION="WYSIWYM (What You See Is What You Mean) document processor based on LaTeX"
+HOMEPAGE="https://www.lyx.org/"
+SRC_URI="http://ftp.lyx.org/pub/lyx/devel/lyx-$(ver_cut 1-2)/${P/_rc/~RC}.tar.xz"
+S=${WORKDIR}/${P/_rc/~RC}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="aspell cups dia dot enchant gnumeric html +hunspell +latex monolithic-build nls rcs rtf svg l10n_he"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ app-text/mythes
+ dev-libs/boost:=
+ sys-apps/file
+ sys-libs/zlib:=
+ virtual/imagemagick-tools[png,svg?]
+ x11-misc/xdg-utils
+
+ dev-qt/qtbase:6[concurrent,dbus,gui,widgets]
+ dev-qt/qt5compat:6
+ dev-qt/qtsvg:6
+
+ aspell? ( app-text/aspell )
+ cups? ( net-print/cups )
+ dia? ( app-office/dia )
+ dot? ( media-gfx/graphviz )
+ enchant? ( app-text/enchant:2 )
+ gnumeric? ( app-office/gnumeric )
+ html? ( dev-tex/html2latex )
+ hunspell? ( app-text/hunspell )
+ l10n_he? (
+ dev-tex/culmus-latex
+ dev-texlive/texlive-langarabic
+ )
+ latex? (
+ app-text/dvipng
+ app-text/ghostscript-gpl
+ app-text/ps2eps
+ app-text/texlive
+ dev-texlive/texlive-fontsrecommended
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-mathscience
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-plaingeneric
+ || (
+ dev-tex/latex2html
+ dev-tex/hevea
+ dev-tex/tex4ht[java]
+ dev-tex/tth
+ )
+ )
+ rcs? ( dev-vcs/rcs )
+ rtf? (
+ app-text/unrtf
+ dev-tex/html2latex
+ dev-tex/latex2rtf
+ )
+ svg? ( || (
+ gnome-base/librsvg
+ media-gfx/inkscape
+ ) )
+"
+DEPEND="${RDEPEND}"
+# bc needed http://comments.gmane.org/gmane.editors.lyx.devel/137498 and bug #787839
+BDEPEND="
+ app-alternatives/bc
+ virtual/pkgconfig
+ dev-qt/qttools[linguist]
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( ANNOUNCE NEWS README RELEASE-NOTES UPGRADING )
+
+FONT_S="${S}/lib/fonts"
+FONT_SUFFIX="ttf"
+
+PATCHES=(
+ "${FILESDIR}"/lyx-2.4.0-fix-hunspell.patch
+ # Try first with xdg-open before hardcoded commands
+ # Patch from Debian using a similar approach to Fedora
+ "${FILESDIR}"/lyx-2.4.0-prefer-xdg-open.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ font_pkg_setup
+}
+
+src_prepare() {
+ sed "s:python -tt:${EPYTHON} -tt:g" -i lib/configure.py || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ #bug 221921
+ export VARTEXFONTS="${T}"/fonts
+
+ local mycmakeargs=(
+ -DLYX_INSTALL=ON
+ -DLYX_USE_QT=QT6
+ -DLYX_INSTALL_PREFIX="${EPREFIX}/usr"
+
+ -DLYX_NLS=$(usex nls)
+ -DLYX_ASPELL=$(usex aspell)
+ -DLYX_ENCHANT=$(usex enchant)
+ -DLYX_HUNSPELL=$(usex hunspell)
+
+ # external dependencies
+ -DLYX_EXTERNAL_Z=ON
+ -DLYX_EXTERNAL_ICONV=ON
+ -DLYX_EXTERNAL_HUNSPELL=ON
+ -DLYX_EXTERNAL_MYTHES=ON
+ -DLYX_EXTERNAL_BOOST=ON
+ -DLYX_PROGRAM_SUFFIX=OFF
+
+ # debug control
+ -DLYX_NO_OPTIMIZE=OFF
+ -DLYX_RELEASE=ON
+ -DLYX_DEBUG=OFF
+ -DLYX_DEBUG_GLIBC=OFF
+ -DLYX_STDLIB_DEBUG=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ newicon -s 32 "development/Win32/packaging/icons/lyx_32x32.png" ${PN}.png
+ doicon -s 48 "lib/images/lyx.png"
+ doicon -s scalable "lib/images/lyx.svg"
+
+ # fix for bug 91108
+ if use latex; then
+ dosym -r /usr/share/lyx/tex /usr/share/texmf-site/tex/latex/lyx
+ fi
+
+ # fonts needed for proper math display, see also bug #15629
+ font_src_install
+
+ python_fix_shebang "${ED}"/usr/share/${PN}
+
+ if use hunspell; then
+ dosym ../myspell /usr/share/lyx/dicts
+ dosym ../myspell /usr/share/lyx/thes
+ fi
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+ xdg_pkg_postinst
+
+ # fix for bug 91108
+ if use latex ; then
+ texhash || die
+ fi
+
+ optfeature "handling more fonts" dev-texlive/texlive-fontsextra
+}
+
+pkg_postrm() {
+ font_pkg_postrm
+ xdg_pkg_postrm
+
+ if use latex ; then
+ texhash || die
+ fi
+}
diff --git a/app-office/lyx/metadata.xml b/app-office/lyx/metadata.xml
index f96a4d3d00ca..7d98136836d7 100644
--- a/app-office/lyx/metadata.xml
+++ b/app-office/lyx/metadata.xml
@@ -1,13 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>aballier@gentoo.org</email>
<name>Alexis Ballier</name>
</maintainer>
- <maintainer type="project">
- <email>cjk@gentoo.org</email>
- <name>Cjk</name>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
</maintainer>
<use>
<flag name="aspell">Add support for aspell spellchecking</flag>