summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/plan/plan-1.10.ebuild')
-rw-r--r--app-office/plan/plan-1.10.ebuild49
1 files changed, 21 insertions, 28 deletions
diff --git a/app-office/plan/plan-1.10.ebuild b/app-office/plan/plan-1.10.ebuild
index bb35e5181561..e16129ffdb18 100644
--- a/app-office/plan/plan-1.10.ebuild
+++ b/app-office/plan/plan-1.10.ebuild
@@ -1,65 +1,58 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Motif based schedule planner"
HOMEPAGE="https://www.bitrot.de/plan.html"
-SRC_URI="ftp://ftp.fu-berlin.de/unix/X11/apps/plan/${P}.tar.gz
- mirror://gentoo/${P}-gentoo.tar.xz"
+SRC_URI="
+ ftp://ftp.fu-berlin.de/unix/X11/apps/plan/${P}.tar.gz
+ https://dev.gentoo.org/~soap/distfiles/${P}-patches.txz"
LICENSE="GPL-2+" #448646
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE=""
-DEPEND="
- x11-libs/libXpm
- >=x11-libs/motif-2.3:0
-"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/motif:0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex"
-QA_PRESTRIPPED="
-/usr/bin/netplan
-/usr/bin/plan
-"
-src_prepare() {
- epatch "${WORKDIR}"/${P}-patches/*.patch
-}
+PATCHES=( "${WORKDIR}"/patches )
src_compile() {
- pushd src
- emake CC=$(tc-getCC) SHARE=/usr/share/plan linux
- popd
+ emake -C src CC="$(tc-getCC)" SHARE=/usr/share/plan linux
}
src_install() {
- pushd src
- emake \
- DESTDIR="${D}" \
+ emake -C src \
+ DESTDIR="${ED}" \
SHARE=/usr/share/plan \
install
keepdir /usr/share/plan/netplan.dir
- popd
dodoc HISTORY README
- pushd misc
+ pushd misc >/dev/null || die
doman netplan.1 plan.1 plan.4
insinto /usr/share/${PN}/misc
doins netplan.boot BlackWhite Monochrome plan.fti Plan.xpm plan.xpm
exeinto /usr/share/${PN}/misc
doexe Killpland cvs vsc msschedule2plan plan2vcs
- popd
+ popd >/dev/null || die
- pushd web
+ pushd web >/dev/null || die
insinto /usr/share/${PN}/web
doins help.html bottom.html cgi-lib.pl common.pl holiday_webplan rtsban.jpg
exeinto /usr/share/${PN}/web
doexe *.cgi
- popd
+ popd >/dev/null || die
}
pkg_postinst() {