summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/scribus/files/scribus-1.5.8-cmake.patch')
-rw-r--r--app-office/scribus/files/scribus-1.5.8-cmake.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-office/scribus/files/scribus-1.5.8-cmake.patch b/app-office/scribus/files/scribus-1.5.8-cmake.patch
new file mode 100644
index 000000000000..6ddd76912dbe
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.5.8-cmake.patch
@@ -0,0 +1,28 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -362,25 +362,6 @@
+ if(APPLE)
+ ### Include our Apple configure commands
+ include(CMakeLists_Apple.cmake)
+-else()
+- if(${CMAKE_GENERATOR} MATCHES "^(Visual Studio|NMake).*")
+- # Windows build with Visual Studio
+- # Surely there's a better way to identify the compiler?
+- set(CMAKE_CXX_FLAGS_DEBUG)
+- set(CMAKE_C_FLAGS_DEBUG)
+- else()
+- # vanilla gcc
+- set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -O0 -g -Wall -fstrict-aliasing")
+- set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -O0 -g -Wall -fstrict-aliasing")
+- endif()
+- if(${CMAKE_GENERATOR} MATCHES "^(Visual Studio|NMake).*")
+- set(CMAKE_CXX_FLAGS_RELEASE)
+- set(CMAKE_C_FLAGS_RELEASE)
+- else()
+- set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -O2 -Wall")
+- set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O2 -Wall")
+- # add_definitions(-DNDEBUG)
+- endif()
+ endif()
+ if(WIN32)
+ add_definitions(-DWIN32_LEAN_AND_MEAN