summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-officeext/languagetool')
-rw-r--r--app-officeext/languagetool/Manifest3
-rw-r--r--app-officeext/languagetool/languagetool-2.5.ebuild26
-rw-r--r--app-officeext/languagetool/languagetool-2.7.ebuild26
-rw-r--r--app-officeext/languagetool/languagetool-2.9.ebuild26
-rw-r--r--app-officeext/languagetool/metadata.xml5
5 files changed, 86 insertions, 0 deletions
diff --git a/app-officeext/languagetool/Manifest b/app-officeext/languagetool/Manifest
new file mode 100644
index 000000000000..e6ec4700fd9e
--- /dev/null
+++ b/app-officeext/languagetool/Manifest
@@ -0,0 +1,3 @@
+DIST LanguageTool-2.5.oxt 46952282 SHA256 0ceb08b67c1d85505f3e97a978316ed54ade4d7bfd6ef848c02b710ee3deee17 SHA512 8813a7d3e4c199d416287ab9af38b8429f7d484bc6e93f775917ba968a302b3a64581588e5464cce9b6b368aabe62576f8cb9d4d8ad27e8d04f1ef622dcd081d WHIRLPOOL 6d2742d11a039953c9c4c728f2188fd3bb5c98f10bfaefb726c38346126359b01a59756c11560e4c0438af9a10dd8cbc80b82787491c90962b770ee614886fa1
+DIST LanguageTool-2.7.oxt 52195597 SHA256 18fa219a674f449cb1925a16dfe6b8f94bfcc1cb678506ce100db361dccdd075 SHA512 6ea98063939e32430adaaf3915776939ed5cd0b43d4fcb70ebd1b0780d844253295bd65e3fa5d745e67947d91613785a6425107f326596fa380f93a02b6508bd WHIRLPOOL 7d26d021b4935680bba696add8e89b11146d40967e60521fc8818bb47975fb082ea42d379e35d9cf5d17ea1c5cabd67baa915a3d9920b2dac4fdf38d4efc9773
+DIST LanguageTool-2.9.oxt 55628675 SHA256 e8d4c262e33a046b57590199b920ff765e6a865c96714f8aac0339f982456cf0 SHA512 eddd2dda2da966beac1fe3a94eb0564e485bc4b45ada9c52dedaba256e8d8d64cb510df4e35f2805ccbae03b5e9d0fde92ec988b01f3c6a0265a6b3eb83fc810 WHIRLPOOL c9dfe02c48e6767beb4406bb54f9279fd71b98cb427225468f5267191e1a9dcc190abc3cedb51c3111caff194550ddd030aa98ef5f874005d7debc21f163de6e
diff --git a/app-officeext/languagetool/languagetool-2.5.ebuild b/app-officeext/languagetool/languagetool-2.5.ebuild
new file mode 100644
index 000000000000..2f2b67877b68
--- /dev/null
+++ b/app-officeext/languagetool/languagetool-2.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="LanguageTool-${PV}"
+
+OFFICE_REQ_USE="java"
+
+OFFICE_EXTENSIONS=(
+ "${MY_P}.oxt"
+)
+
+inherit office-ext-r1
+
+DESCRIPTION="Style and Grammar Checker for libreoffice"
+HOMEPAGE="http://www.languagetool.org/"
+SRC_URI="http://www.languagetool.org/download/${MY_P}.oxt"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=virtual/jdk-1.6"
diff --git a/app-officeext/languagetool/languagetool-2.7.ebuild b/app-officeext/languagetool/languagetool-2.7.ebuild
new file mode 100644
index 000000000000..82c0cc51fc24
--- /dev/null
+++ b/app-officeext/languagetool/languagetool-2.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="LanguageTool-${PV}"
+
+OFFICE_REQ_USE="java"
+
+OFFICE_EXTENSIONS=(
+ "${MY_P}.oxt"
+)
+
+inherit office-ext-r1
+
+DESCRIPTION="Style and Grammar Checker for libreoffice"
+HOMEPAGE="http://www.languagetool.org/"
+SRC_URI="http://www.languagetool.org/download/${MY_P}.oxt"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jdk-1.7"
diff --git a/app-officeext/languagetool/languagetool-2.9.ebuild b/app-officeext/languagetool/languagetool-2.9.ebuild
new file mode 100644
index 000000000000..006d776bd7e3
--- /dev/null
+++ b/app-officeext/languagetool/languagetool-2.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="LanguageTool-${PV}"
+
+OFFICE_REQ_USE="java"
+
+OFFICE_EXTENSIONS=(
+ "${MY_P}.oxt"
+)
+
+inherit office-ext-r1
+
+DESCRIPTION="Style and Grammar Checker for libreoffice"
+HOMEPAGE="http://www.languagetool.org/"
+SRC_URI="http://www.languagetool.org/download/${MY_P}.oxt"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jdk-1.7"
diff --git a/app-officeext/languagetool/metadata.xml b/app-officeext/languagetool/metadata.xml
new file mode 100644
index 000000000000..5d46203011d6
--- /dev/null
+++ b/app-officeext/languagetool/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openoffice</herd>
+</pkgmetadata>