summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/orange')
-rw-r--r--app-pda/orange/Manifest1
-rw-r--r--app-pda/orange/metadata.xml12
-rw-r--r--app-pda/orange/orange-0.4.ebuild37
3 files changed, 50 insertions, 0 deletions
diff --git a/app-pda/orange/Manifest b/app-pda/orange/Manifest
new file mode 100644
index 000000000000..1019eb23e223
--- /dev/null
+++ b/app-pda/orange/Manifest
@@ -0,0 +1 @@
+DIST liborange-0.4.tar.gz 330089 SHA256 023fc4ecdd4e775023b89d8fea37918ed8ba55012578e4f7ac0ec3cd1e843fbe SHA512 62ac6687c7d6bfd12d6adce5eecdf9388f719c65127bda3ba8e54750cc8bc8e239286859fcbeed7acdce866f32793e3aabbe943c08f1403b5863300c817772b2 WHIRLPOOL 9cc179e000d9620136e725f07d64bd45942c24fa74d4c735becb35803b1d6090f488ae09dbbdee645cd113a40c79bcaade4e4a517c883d222b6c4408e71b75d5
diff --git a/app-pda/orange/metadata.xml b/app-pda/orange/metadata.xml
new file mode 100644
index 000000000000..b5cb338a8f87
--- /dev/null
+++ b/app-pda/orange/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>pda</herd>
+ <longdescription>
+ Orange is a tool and library for squeezing out juicy installable Microsoft
+ Cabinet Files from self-extracting installers for Microsoft Windows
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">synce</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-pda/orange/orange-0.4.ebuild b/app-pda/orange/orange-0.4.ebuild
new file mode 100644
index 000000000000..1b7bd82f9b35
--- /dev/null
+++ b/app-pda/orange/orange-0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_P=lib${P}
+
+DESCRIPTION="A tool and library for extracting cabs from executable installers"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+SRC_URI="mirror://sourceforge/synce/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="app-pda/synce-core
+ >=app-pda/dynamite-0.1.1
+ >=app-arch/unshield-0.6
+ sys-apps/file
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="ChangeLog TODO"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}