summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/coldsync/Manifest2
-rw-r--r--app-pda/coldsync/coldsync-2.2.5-r1.ebuild76
-rw-r--r--app-pda/coldsync/coldsync-3.0_pre4.ebuild87
-rw-r--r--app-pda/coldsync/files/coldsync-2.2.5-toolchain.patch25
-rw-r--r--app-pda/coldsync/files/coldsync-3.0_pre4-texinfo-5.patch27
-rw-r--r--app-pda/coldsync/metadata.xml5
-rw-r--r--app-pda/jpilot-syncmal/Manifest1
-rw-r--r--app-pda/jpilot-syncmal/jpilot-syncmal-0.81.ebuild38
-rw-r--r--app-pda/jpilot-syncmal/metadata.xml5
-rw-r--r--app-pda/synce-sync-engine/Manifest1
-rw-r--r--app-pda/synce-sync-engine/metadata.xml8
-rw-r--r--app-pda/synce-sync-engine/synce-sync-engine-0.15.1-r3.ebuild49
12 files changed, 0 insertions, 324 deletions
diff --git a/app-pda/coldsync/Manifest b/app-pda/coldsync/Manifest
deleted file mode 100644
index 9d7d72fe9903..000000000000
--- a/app-pda/coldsync/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST coldsync-2.2.5.tar.gz 663307 SHA256 635575e2175a865827319ad21cbfbac95a42a7256730898ae9e9104b63b4fef6 SHA512 94ca6f3cff2248563c9a179d052f1e31f9482a62bd6988baecdb0fd8d9ed376c7653eba15448a8be1585d0ab0f727597985d459fd063fe70a4b77a9ed9298a7a WHIRLPOOL 85f1fe15299f024b6bc9d86127f146298c805adfe46009f90a2ae171e1f3c217a7708bbd8111095e0102cae4bdf1c508ce0bdfe66bf118813ca14026f1f79fa8
-DIST coldsync-3.0-pre4.tar.gz 657305 SHA256 ca32dbcd1b2d3cbce8ee4e34aafb1183fc09c3ead69d308e76454a9c4c4728c3 SHA512 9f8ad373b2613388dfa47c86a65c05378f66b59ce09e5c984617fbb72525a5f31f90dd09a22258ada469a29278cdd442632747c8d2f924372bfbd6e0ba4bec22 WHIRLPOOL e05cee91e61cdd979efcab168d10834f9b0fb8e19a3a488efa99b910490051857358a3c9c9c548acb62b9fcd96268b7d717549f6a9882c434446729af928ba9f
diff --git a/app-pda/coldsync/coldsync-2.2.5-r1.ebuild b/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
deleted file mode 100644
index 6d5af383f7d4..000000000000
--- a/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit eutils flag-o-matic perl-module toolchain-funcs
-
-DESCRIPTION="A command-line tool to synchronize PalmOS PDAs with Unix workstations"
-HOMEPAGE="http://www.coldsync.org/"
-SRC_URI="http://www.coldsync.org/download/${P}.tar.gz"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~sparc x86"
-IUSE="nls perl"
-
-RDEPEND="perl? ( dev-lang/perl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-toolchain.patch
-
- if use perl; then
- pushd perl/ColdSync
- perl-module_src_prepare
- popd
- fi
-}
-
-src_configure() {
- tc-export CC CXX
- append-cflags -fno-strict-aliasing
-
- # TODO: i18n: msgfmt fails but doesn't || die
- econf \
- $(use_with nls i18n) \
- --without-perl
-
- if use perl; then
- pushd perl/ColdSync
- perl-module_src_configure
- popd
- fi
-}
-
-src_compile() {
- default
-
- if use perl; then
- pushd perl/ColdSync
- perl-module_src_compile
- popd
- fi
-}
-
-src_install() {
- emake \
- PREFIX="${D}"/usr \
- MANDIR="${D}"/usr/share/man \
- SYSCONFDIR="${D}"/etc \
- DATADIR="${D}"/usr/share \
- INFODIR="${D}"/usr/share/info \
- INSTALLMAN3DIR="${D}"/usr/share/man/man3 \
- INSTALLSITEMAN3DIR="${D}"/usr/share/man/man3 \
- INSTALLVENDORMAN3DIR="${D}"/usr/share/man/man3 \
- install
-
- if use perl; then
- pushd perl/ColdSync
- perl-module_src_install
- popd
- fi
-
- dodoc AUTHORS ChangeLog FAQ HACKING NEWS README* TODO
-}
diff --git a/app-pda/coldsync/coldsync-3.0_pre4.ebuild b/app-pda/coldsync/coldsync-3.0_pre4.ebuild
deleted file mode 100644
index aa1d65f6ccb0..000000000000
--- a/app-pda/coldsync/coldsync-3.0_pre4.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit flag-o-matic eutils perl-module toolchain-funcs
-
-MY_P=${PN}-${PV/_/-}
-
-DESCRIPTION="A command-line tool to synchronize PalmOS PDAs with Unix workstations"
-HOMEPAGE="http://www.coldsync.org/"
-SRC_URI="http://www.coldsync.org/download/${MY_P}.tar.gz"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="caps nls perl usb"
-
-RDEPEND="caps? ( sys-libs/libcap )
- perl? ( dev-lang/perl )
- usb? ( virtual/libusb:0 )"
-DEPEND="${RDEPEND}
- sys-apps/texinfo
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-texinfo-5.patch
-
- if use perl; then
- pushd perl/ColdSync
- perl-module_src_prepare
- popd
- fi
-}
-
-src_configure() {
- tc-export CC CXX
- append-cflags -fno-strict-aliasing
- # FIXME: Fails to link later because libpconn is underlinked with USE="usb".
- append-ldflags $(no-as-needed)
-
- econf \
- $(use_with nls i18n) \
- $(use_with caps capabilities) \
- $(use_with usb libusb) \
- --without-perl
-
- if use perl; then
- pushd perl/ColdSync
- perl-module_src_configure
- popd
- fi
-}
-
-src_compile() {
- emake -j1 #279292
-
- if use perl; then
- pushd perl/ColdSync
- perl-module_src_compile
- popd
- fi
-}
-
-src_install() {
- emake \
- PREFIX="${D}"/usr \
- MANDIR="${D}"/usr/share/man \
- SYSCONFDIR="${D}"/etc \
- DATADIR="${D}"/usr/share \
- INFODIR="${D}"/usr/share/info \
- INSTALLMAN3DIR="${D}"/usr/share/man/man3 \
- INSTALLSITEMAN3DIR="${D}"/usr/share/man/man3 \
- INSTALLVENDORMAN3DIR="${D}"/usr/share/man/man3 \
- EXTRA_INFOFILES="" \
- install
-
- if use perl; then
- pushd perl/ColdSync
- perl-module_src_install
- popd
- fi
-
- dodoc AUTHORS ChangeLog FAQ HACKING NEWS README* TODO
-}
diff --git a/app-pda/coldsync/files/coldsync-2.2.5-toolchain.patch b/app-pda/coldsync/files/coldsync-2.2.5-toolchain.patch
deleted file mode 100644
index 1a5392d97f0b..000000000000
--- a/app-pda/coldsync/files/coldsync-2.2.5-toolchain.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/symboltable.cc
-+++ src/symboltable.cc
-@@ -11,8 +11,11 @@
- #include <string>
- #include <map>
- #include <cstdlib> // For malloc() and friends
-+#include <cstring> // For strlen() and friends
- #include "symboltable.h"
-
-+using namespace std;
-+
- static char *make_c_string(const string &s);
-
- map<string,string> table; /* XXX - Is this going to cause problems on
---- src/symboltable.h
-+++ src/symboltable.h
-@@ -26,7 +26,7 @@
- /* Initialize the symbol table based on the
- * arguments. */
- #ifdef __cplusplus
--};
-+}
- #endif /* __cplusplus */
-
- /* This is for Emacs's benefit:
diff --git a/app-pda/coldsync/files/coldsync-3.0_pre4-texinfo-5.patch b/app-pda/coldsync/files/coldsync-3.0_pre4-texinfo-5.patch
deleted file mode 100644
index 0579a9fb854e..000000000000
--- a/app-pda/coldsync/files/coldsync-3.0_pre4-texinfo-5.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Fix building against texinfo >= 5.0
-
-http://bugs.gentoo.org/514772
-http://www.gnu.org/software/texinfo/manual/texinfo/texinfo.html#g_t_0040copyright
-
---- doc/conduits.texi
-+++ doc/conduits.texi
-@@ -33,7 +33,7 @@
-
- @page
- @vskip 0pt plus 1filll
--Copyright @copyright 2000 Andrew Arensburger.
-+Copyright @copyright{} 2000 Andrew Arensburger.
-
- Permission is granted to make and distribute verbatim copies of
- this manual provided the copyright notice and this permission notice
---- doc/libpalm.texi
-+++ doc/libpalm.texi
-@@ -57,7 +57,7 @@
-
- @page
- @vskip 0pt plus 1filll
--Copyright @copyright 1999 Andrew Arensburger.
-+Copyright @copyright{} 1999 Andrew Arensburger.
-
- Permission is granted to make and distribute verbatim copies of
- this manual provided the copyright notice and this permission notice
diff --git a/app-pda/coldsync/metadata.xml b/app-pda/coldsync/metadata.xml
deleted file mode 100644
index 6f49eba8f496..000000000000
--- a/app-pda/coldsync/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/app-pda/jpilot-syncmal/Manifest b/app-pda/jpilot-syncmal/Manifest
deleted file mode 100644
index f1986cd7db62..000000000000
--- a/app-pda/jpilot-syncmal/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST jpilot-syncmal-0.81.tar.gz 347999 SHA256 2724453b671c867207a5597f9648b455740d97673efe9e6c174beced7a5fb24a SHA512 a5c47ade0e15fc47eb15d9fc7ea98d01d36c790af0f32bb27aa4299409b9bd35c4a2c850422ba939d1a6c826fbf97d188f6283e47234a49103235dd2bc38d353 WHIRLPOOL d433e579ada2dd083da1f7dc8d6f1169751fcb90f8391278f03d24532a5d90af0da1b4fb07be75e8d5df51c676e17f2b6d75044b0b248da01110b9b84cfdc82b
diff --git a/app-pda/jpilot-syncmal/jpilot-syncmal-0.81.ebuild b/app-pda/jpilot-syncmal/jpilot-syncmal-0.81.ebuild
deleted file mode 100644
index 7208a82ed198..000000000000
--- a/app-pda/jpilot-syncmal/jpilot-syncmal-0.81.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=2
-inherit multilib
-
-DESCRIPTION="Syncmal plugin for jpilot"
-HOMEPAGE="http://www.jlogday.com/code/syncmal/index.html"
-SRC_URI="http://www.jlogday.com/code/syncmal/${P}.tar.gz"
-
-LICENSE="GPL-2 MPL-1.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND=">=app-pda/jpilot-0.99.9
- >=app-pda/pilot-link-0.12.3
- >=x11-libs/gtk+-2.8.19:2
- >=dev-libs/libmal-0.44"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_configure() {
- econf \
- --enable-gtk2
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- libdir="/usr/$(get_libdir)/jpilot/plugins" \
- install || die
-
- dodoc AUTHORS README TODO
-
- find "${D}" -name '*.la' -delete
-}
diff --git a/app-pda/jpilot-syncmal/metadata.xml b/app-pda/jpilot-syncmal/metadata.xml
deleted file mode 100644
index 6f49eba8f496..000000000000
--- a/app-pda/jpilot-syncmal/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/app-pda/synce-sync-engine/Manifest b/app-pda/synce-sync-engine/Manifest
deleted file mode 100644
index 2de5293449d9..000000000000
--- a/app-pda/synce-sync-engine/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST synce-sync-engine-0.15.1.tar.gz 173406 SHA256 bdee6ba59d3106768dbe61f4f353ae2b59cbf1112cd274128f52a86d180370c4 SHA512 ef4855c24e8bff7da0e3eeccfc495e98ccd3817f20683f9648b6370cef05a22fa49ce19514efea9936d416120a7881ef930b433d7800b2f19c11ceb585aff827 WHIRLPOOL 534acbcf3abd29235d1073c96157832631ca1a408b8ed3fa4571daa09e7ee74c4a2ac73d5262cdae6bf353a563ea7be9dac5985d41fa2b00694576cc24751fd3
diff --git a/app-pda/synce-sync-engine/metadata.xml b/app-pda/synce-sync-engine/metadata.xml
deleted file mode 100644
index 6bf8d23c773d..000000000000
--- a/app-pda/synce-sync-engine/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="sourceforge">synce</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/app-pda/synce-sync-engine/synce-sync-engine-0.15.1-r3.ebuild b/app-pda/synce-sync-engine/synce-sync-engine-0.15.1-r3.ebuild
deleted file mode 100644
index ba295f33cdf6..000000000000
--- a/app-pda/synce-sync-engine/synce-sync-engine-0.15.1-r3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.7"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils multilib
-
-DESCRIPTION="A synchronization engine for SynCE"
-HOMEPAGE="https://sourceforge.net/projects/synce/"
-SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="app-pda/synce-core[python]
- >=dev-libs/librra-0.16[python]
- >=dev-libs/librtfcomp-1.2[python]
- dev-libs/libxml2[python]
- dev-libs/libxslt[python]
- dev-python/dbus-python
- dev-python/pygobject:2"
-DEPEND=${RDEPEND}
-
-PYTHON_MODNAME=SyncEngine
-
-src_prepare() {
- sed -i -e 's:share/doc/sync-engine:foobar:' setup.py || die
-
- distutils_src_prepare
-}
-
-src_install() {
- insinto /usr/share/dbus-1/services
- doins config/org.synce.SyncEngine.service || die
-
- insinto /etc
- doins config/syncengine.conf.xml || die
-
- distutils_src_install
-
- rm -rf "${ED}"/usr/foobar
-}