summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libimobiledevice/libimobiledevice-1.3.0-r1.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/app-pda/libimobiledevice/libimobiledevice-1.3.0-r1.ebuild b/app-pda/libimobiledevice/libimobiledevice-1.3.0-r1.ebuild
index a2de4548e907..2ab8f78335dd 100644
--- a/app-pda/libimobiledevice/libimobiledevice-1.3.0-r1.ebuild
+++ b/app-pda/libimobiledevice/libimobiledevice-1.3.0-r1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit autotools python-r1
@@ -12,9 +13,7 @@ SRC_URI="https://github.com/libimobiledevice/libimobiledevice/releases/download/
# While COPYING* doesn't mention 'or any later version', all the headers do, hence use +
LICENSE="GPL-2+ LGPL-2.1+"
-
SLOT="0/1.0-6" # based on SONAME of libimobiledevice-1.0.so
-
KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 x86"
IUSE="doc gnutls python static-libs"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -25,19 +24,19 @@ RDEPEND="
gnutls? (
dev-libs/libgcrypt:0
>=dev-libs/libtasn1-1.1
- >=net-libs/gnutls-2.2.0 )
+ >=net-libs/gnutls-2.2.0
+ )
!gnutls? (
dev-libs/openssl:0=
)
python? (
${PYTHON_DEPS}
- app-pda/libplist[python(-),${PYTHON_USEDEP}] )
+ app-pda/libplist[python(-),${PYTHON_USEDEP}]
+ )
"
-
DEPEND="
${RDEPEND}
"
-
BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen )