summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/command-not-found')
-rw-r--r--app-portage/command-not-found/Manifest1
-rw-r--r--app-portage/command-not-found/command-not-found-0.0.5.ebuild40
-rw-r--r--app-portage/command-not-found/metadata.xml12
3 files changed, 53 insertions, 0 deletions
diff --git a/app-portage/command-not-found/Manifest b/app-portage/command-not-found/Manifest
new file mode 100644
index 000000000000..abd98307c6b6
--- /dev/null
+++ b/app-portage/command-not-found/Manifest
@@ -0,0 +1 @@
+DIST command-not-found-0.0.5.tar.gz 10045 BLAKE2B 5225fe4512516518172b1c7d25563488f26b359e0698a3352ebf2143dd7983fee2c44050e2b4abf72377780875436861855f0891bc10d429fba9bba695808bf3 SHA512 9125e168d64b7474f83d1bc8ed7f54ef332190d0d7325c281f1a041d47b23ce18170dff2fa3342468941cba7b0197821790ef5d1e9b8c1ee1f5a6ba1383b1005
diff --git a/app-portage/command-not-found/command-not-found-0.0.5.ebuild b/app-portage/command-not-found/command-not-found-0.0.5.ebuild
new file mode 100644
index 000000000000..40a16ef01bc3
--- /dev/null
+++ b/app-portage/command-not-found/command-not-found-0.0.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit optfeature python-r1
+
+DESCRIPTION="Command-not-found handler for Gentoo"
+HOMEPAGE="https://github.com/AndrewAmmerlaan/command-not-found-gentoo"
+SRC_URI="https://github.com/AndrewAmmerlaan/command-not-found-gentoo/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-gentoo-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+src_install() {
+ python_foreach_impl python_doscript command-not-found
+
+ insinto /etc/bash/bashrc.d
+ doins command-not-found.sh
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "${PN} is automatically setup for app-shells/bash, see"
+ elog " /usr/share/doc/${PF}/README.md"
+ elog "for instructions on how to set it up for various other shells."
+ elog
+ optfeature "suggesting snaps providing the missing command" "app-containers/snapd"
+ optfeature "suggesting ebuilds providing the missing command" "app-portage/pfl"
+}
diff --git a/app-portage/command-not-found/metadata.xml b/app-portage/command-not-found/metadata.xml
new file mode 100644
index 000000000000..87d84e421471
--- /dev/null
+++ b/app-portage/command-not-found/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">AndrewAmmerlaan/command-not-found-gentoo</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>