summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/esearch/esearch-9999.ebuild')
-rw-r--r--app-portage/esearch/esearch-9999.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/app-portage/esearch/esearch-9999.ebuild b/app-portage/esearch/esearch-9999.ebuild
index d3487f839a86..db0abe567e95 100644
--- a/app-portage/esearch/esearch-9999.ebuild
+++ b/app-portage/esearch/esearch-9999.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="readline(+)"
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 git-r3
@@ -18,19 +19,19 @@ IUSE="l10n_fr l10n_it"
KEYWORDS=""
+BDEPEND="${DISTUTILS_DEPS}"
DEPEND="sys-apps/portage"
RDEPEND="${DEPEND}"
-python_prepare_all() {
- python_export_best
- echo VERSION="9999-${EGIT_VERSION}" "${PYTHON}" setup.py set_version
- VERSION="9999-${EGIT_VERSION}" "${PYTHON}" setup.py set_version
- distutils-r1_python_prepare_all
+python_configure_all() {
+ echo VERSION="${PVR}" "${EPYTHON}" setup.py set_version
+ VERSION="${PVR}" "${EPYTHON}" setup.py set_version \
+ || die "setup.py set_version failed"
}
python_install_all() {
distutils-r1_python_install_all
- dodoc eupdatedb.cron || die "dodoc failed"
+ dodoc eupdatedb.cron
# Remove unused man pages according to the l10n flags
if ! use l10n_fr ; then