summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/flaggie')
-rw-r--r--app-portage/flaggie/Manifest2
-rw-r--r--app-portage/flaggie/flaggie-0.2.1-r1.ebuild37
-rw-r--r--app-portage/flaggie/flaggie-0.99.8.ebuild32
-rw-r--r--app-portage/flaggie/flaggie-9999.ebuild38
-rw-r--r--app-portage/flaggie/metadata.xml10
5 files changed, 37 insertions, 82 deletions
diff --git a/app-portage/flaggie/Manifest b/app-portage/flaggie/Manifest
index 1d01791c764a..5fef7c992c09 100644
--- a/app-portage/flaggie/Manifest
+++ b/app-portage/flaggie/Manifest
@@ -1 +1 @@
-DIST flaggie-0.2.1.tar.bz2 16767 BLAKE2B fea0fbc505bfa97e7bee2c05f0cc19077b9b23a021b01aafa2c4b064466677f9dd4ae95c36f6de65b4ad07c5046d539ceb0cb667dcb791b60410d7a5e688813f SHA512 3f273ebeceaaedce7a3807126fb3f450e420338a883440066d06a4d6a95b63bd538bb5da882fea23e0d390b28a83f50375dbda2624f656327775b2b700f2b2e4
+DIST flaggie-0.99.8.tar.gz 17865 BLAKE2B af52f5c030ff81ebd1efac6c02a736c87d0ce8f953722f0f364adf7ace74a26245fb43fb5ba96000fb2da391ff90c6c682522fc5a7725fca0289c1063e4704ac SHA512 77265b2958210a9643776dfaad65d00cd511b2b8d1cedd397c6712559af9c7d671cf286eabd0c866b10408429829615cd2f2b7c3013a99d470be8f2f7e8cccfb
diff --git a/app-portage/flaggie/flaggie-0.2.1-r1.ebuild b/app-portage/flaggie/flaggie-0.2.1-r1.ebuild
deleted file mode 100644
index ccf3b152e2ca..000000000000
--- a/app-portage/flaggie/flaggie-0.2.1-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="A smart CLI mangler for package.* files"
-HOMEPAGE="https://github.com/mgorny/flaggie/"
-SRC_URI="https://github.com/mgorny/flaggie/releases/download/${P}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~mips ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="sys-apps/portage[${PYTHON_USEDEP}]"
-
-python_install_all() {
- newbashcomp contrib/bash-completion/${PN}.bash-completion ${PN}
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- ewarn "Please note that flaggie creates backups of your package.* files"
- ewarn "before performing each change through appending a single '~'."
- ewarn "If you'd like to keep your own backup of them, please use another"
- ewarn "naming scheme (or even better some VCS)."
- if ! has_version app-shells/gentoo-bashcomp; then
- elog
- elog "If you want to use bash-completion, you need to install:"
- elog " app-shells/gentoo-bashcomp"
- fi
-}
diff --git a/app-portage/flaggie/flaggie-0.99.8.ebuild b/app-portage/flaggie/flaggie-0.99.8.ebuild
new file mode 100644
index 000000000000..6b637e334d74
--- /dev/null
+++ b/app-portage/flaggie/flaggie-0.99.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A smart CLI mangler for package.* files"
+HOMEPAGE="
+ https://github.com/projg2/flaggie/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~mips ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=app-portage/gentoopm-0.5.0[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-vcs/git
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ ewarn "This is a preview release of flaggie 1.x. It it not fully featured"
+ ewarn "yet and it may have significant bugs. Please back your /etc/portage"
+ ewarn "up before using it. Verify the results using --pretend."
+}
diff --git a/app-portage/flaggie/flaggie-9999.ebuild b/app-portage/flaggie/flaggie-9999.ebuild
deleted file mode 100644
index 054c1c210325..000000000000
--- a/app-portage/flaggie/flaggie-9999.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7..9} )
-
-EGIT_REPO_URI="https://github.com/mgorny/flaggie.git"
-inherit bash-completion-r1 distutils-r1 git-r3
-
-DESCRIPTION="A smart CLI mangler for package.* files"
-HOMEPAGE="https://github.com/mgorny/flaggie/"
-SRC_URI=""
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-RDEPEND="sys-apps/portage[${PYTHON_USEDEP}]"
-
-python_install_all() {
- newbashcomp contrib/bash-completion/${PN}.bash-completion ${PN}
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- ewarn "Please note that flaggie creates backups of your package.* files"
- ewarn "before performing each change through appending a single '~'."
- ewarn "If you'd like to keep your own backup of them, please use another"
- ewarn "naming scheme (or even better some VCS)."
- if ! has_version app-shells/gentoo-bashcomp; then
- elog
- elog "If you want to use bash-completion, you need to install:"
- elog " app-shells/gentoo-bashcomp"
- fi
-}
diff --git a/app-portage/flaggie/metadata.xml b/app-portage/flaggie/metadata.xml
index c7ed5cc31b68..d210fbb38849 100644
--- a/app-portage/flaggie/metadata.xml
+++ b/app-portage/flaggie/metadata.xml
@@ -5,12 +5,10 @@
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
- <maintainer status="active">
- <email>mgorny@gentoo.org</email>
- <name>Michał Górny</name>
- </maintainer>
- <bugs-to>https://github.com/mgorny/flaggie/issues/</bugs-to>
- <remote-id type="github">mgorny/flaggie</remote-id>
+ <bugs-to>https://github.com/projg2/flaggie/issues/</bugs-to>
+ <remote-id type="github">projg2/flaggie</remote-id>
+ <remote-id type="pypi">flaggie</remote-id>
</upstream>
</pkgmetadata>