summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/g-octave/files/g-octave-0.4.1-fix-Makefile.patch')
-rw-r--r--app-portage/g-octave/files/g-octave-0.4.1-fix-Makefile.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/app-portage/g-octave/files/g-octave-0.4.1-fix-Makefile.patch b/app-portage/g-octave/files/g-octave-0.4.1-fix-Makefile.patch
new file mode 100644
index 000000000000..53d3d5e0dbcd
--- /dev/null
+++ b/app-portage/g-octave/files/g-octave-0.4.1-fix-Makefile.patch
@@ -0,0 +1,12 @@
+--- share/g-octave.eclass 2013-05-30 19:01:07.980521612 +0200
++++ share/g-octave.eclass.new 2013-05-30 19:03:38.933514388 +0200
+@@ -48,6 +48,9 @@
+ for filename in Makefile configure; do
+ cp "${DISTDIR}/g-octave_${filename}" "${S}/${filename}"
+ done
++
++ sed -i -e 's@libexec@lib@g' "${S}/Makefile" || die 'sed failed.'
++
+ chmod 0755 "${S}/configure"
+ if [ -e "${S}"/src/autogen.sh ]; then
+ cd "${S}"/src && ./autogen.sh || die 'failed to run autogen.sh'